Jump to content

eldericmk

Members
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About eldericmk

  • Rank
    Peon

Personal Information

  • Name
    Marcus König
  • Location
    Germany
  1. Hi there, I'm trying to wrap my head around renderman 20 in houdini 15.5. Now there's a tricky thing with displacements going on. When building stuff, I usually group the entire object in a single geometry node via subnet and combines, applying materials via the material SOP and specific groupings of the underlying geometry. this in turn creates a string attribute on the selected primitives with name “shop_materialpath” and the given path to the pxrWhatever shader. stuff shows up in RIS renders, everything behaves as expected. fine. this would behave equally, if I just added the “shop_materialpath” via AttributeCreate and the proper path to the shader by hand on a primitive. however, now I want to displace something. the only working way in renderman 20 seems to be to create a pxrDisplacement with some input (f.e. pxrWorley) and add the rendering parameters “Displacement Shader” (shop_displacepath) and “Displacement Bound” (ri_dbound) to the geometry node in /obj. Apply the shader, set bound > 0, displacement shows up in renders. fine. BUT: Now I thought: “Hah. Just transfer these parameters on a primitive base via AttributeCreate as well, done.”. However this doesn't seem to work. Instead I have to extract the geo into a second geometry node in /obj via ObjectMerge and again apply the said parameters on the top-level geometry node itself. Are “shop_displacepath” and “ri_dbound” not assignable to primitives by hand? Or am I missing a crucial step? Perhaps something else has to be applied as well? Any Ideas? -Marcus
×