Jump to content

ntkirby

Members
  • Content count

    74
  • Donations

    0.00 CAD 
  • Joined

  • Last visited

Everything posted by ntkirby

  1. Hello everyone... I have a problem with an RBD packed object inheriting velocity. In the file, I have the attribute active being set by another object, but the velocity doesn't kick in at all. The velocity works if I remove the point wrangle setting active to 0 and remove the sop solver. If I try a pop vop or a geo vop, there's some weird velocity behavior that happens. If I tick on override attribute, the velocity takes off big time and doesn't appear that gravity takes hold. All I'm looking for is initial velocity once the pieces become active. I saw a few threads on the side fx forums and this forum, but nothing I saw seems to be working. Any thoughts? test_active_velocity.hipnc
  2. inherit velocity RBD Packed Object

    Wow, ok... so I just learned something new again I apologize to @cwhite I just need to be properly educated Thanks again @julian johnson
  3. inherit velocity RBD Packed Object

    @cwhite - Thanks for the help, I tried to set the animated value but it didn't work out. The solutions mentioned above worked out.
  4. inherit velocity RBD Packed Object

    @cwhite I'm using 16.0.608 am I missing something though in my setup? The active attribute starts at 0 and at some frame later changes to 1, but the velocity doesn't transfer.
  5. inherit velocity RBD Packed Object

    @julian johnson - I saw the post here so I decided to try it. It worked, so I went ahead and tried some other things outside of using wrangles to see what I could accomplish and I get some odd results. I'll take a look at his H16 file and see if anything else is going on...I'll check yours too when I get home.
  6. inherit velocity RBD Packed Object

    @julian johnson I looked at the file, it wasn't what I was looking for....for whatever reason, it's not keeping the initial velocity on the pieces when they are inactive. I want the velocity to take off as the objects become active. It doesn't matter whether I inherit velocity or even use the velocity on the rbd packed object to do it, it just won't do what I want.
  7. inherit velocity RBD Packed Object

    @Dam: When I was looking at the spreadsheet in the DOP network, I noticed using the active attribute that the velocity was being reset as opposed to when I didn't explicitly define that attribute and using the sop solver... @Varishtraheja: Not what I wanted. The animation needs to break apart like it's being affected by wind. Look at this:
  8. Houdini and MP3

    I don't know what I did the first time I tried to convert it to a .wav file, but this time it worked... this is wierd... Thanks for the help!
  9. Houdini and MP3

    I did a search for MP3 and nothing came up... I'm wondering why Houdini would be able to read the sound from one MP3 but not another even though nothing errors out? It's just one MP3 file too...so I'm not sure why there's nothing that comes up in the time slider....I made sure the windows permissions on the files were the same, it plays in Windows Media Player just fine... so I'm out of answers....
  10. Flip collisions with VDB

    Thanks for the help Dam... it looks like I just need to get rid of the velocity after I write it out and bring it back in.... I think it's coming from the point vop and it's just not really writing it out from the dop network... or just use that trail sop before bringing it into the flip sim.. either way, we figured it out!
  11. Hello to all... I have a scene where I have animated geometry written out and I bring it back in via a file sop. The animation is just of some rocks flying up in the air flying down inside some water. I'm using a vdb from polygons on the file and I'm bringing that into the dop network as a static object with the mode set to Volume Sample and pointing to the object in the proxy volume field . The problem I run into is when the rocks collide with the fluid, the fluid collapses. I can remove the proxy volume and reset the mode to ray intersect and things will be fine....I have tried to explore on how to fix this but I can't seem to find the solution... does anyone have any ideas? I can upload the scene later if needed. flip_tests.hipnc
  12. Flip collisions with VDB

    That's what that is.. POP Advect by Volumes... that's why it was plugged into the third input... I'm grabbing the velocity volume from the ocean source node and blast anything not @name=vel.*
  13. Flip collisions with VDB

    Ok, so... I just did a quick test with the popadvectbyvolume in both inputs and removing it altogether with and without the trail sop, and on my end, without that trail sop on the unpacked object... the fluid collapsed....without the trail sop.... it's wierd
  14. Flip collisions with VDB

    Here's my file with that... I'm going to do some more tests with the popadvectbyvolume in the particle velocity input and see what that does...that's interesting flip_tests2.hipnc
  15. Flip collisions with VDB

    Ok, so ... after looking at your files, I decided to do a little troubleshooting on my own based off your findings....and It looks like all I needed to do was add a trail sop in..and it wouldn't make the volume collapse... Now, as far as the collision separation, I played around turning it on and off and matching the vdb resolution to that value... what I found was that even though it didn't affect the particles (as long as I had that trail sop in) it still showed slightly weird behavior if I didn't match the resolutions.. if I made collision separation different than the particle separation, I would still get a little weird behavior... So... Add a trail sop after the animated objects before bringing them into flips... vdb resoltuion = collision separation = particle separation
  16. Flip collisions with VDB

    Ok, I uploaded the file!! You'd figure I would know better since I've posted in these forums in the past
  17. DEM data to Houdini?

    I posted this also in the SideFX forums... I've been searching for a way to convert the maps I download, MicroDEM produces memory leaks, PullSDTS is no where to be found.... I'm trying to convert these maps to images to use to create terrain Does anyone have any suggestions?
  18. Waterfall and large robot sim

    Hello everyone! So I have a small issue I've been working through trial and error through and found some pretty interesting results and am trying to get some feedback on how best to approach the problem of scale. Below is a video of a robot coming out of a waterfall. You might say I kind of want this to be Pacific Rim type, the robot is huge, about 200 feet tall/61 meters and the waterfall is a little taller So in troubleshooting this I found there were at least 3 parameters that need to be set: gravity, density, and spatial scale. There are probably more but I haven't encountered them yet. Changing the units in the preferences before putting down the nodes will automatically set these. Another way I'm attempting to resolve this is by actually scaling the objects up to actual size to see how it goes. I'm also trying a different method that was suggested to me...modifying the scale time parameter on the dop net. I've been looking through the forums to see how others have approached this issue, but I'm coming up a bit short. Does anyone have any useful methods of approaching a large scale simulation like this?
  19. flip sim losing volume

    Hey all, I'm working on a small school project involving flip fluids, is it normal for a flip sim to lose volume as the resolution gets pumped up? I'm trying to simulate an interaction between oil and water.... I'm using a particle tank sop in the flip object for the initial particles and using a sphere to emit the oil. The volume of the entire liquid in the box I made doesn't seem to change when I lower the particle separation, but as more particles get introduced when I lower the particle separation. I'm not sure what's causing it... After further testing it does appear that even without the 2nd liquid, the fluid compresses...particles don't get lost, it just compresses... oil_water_bunny.hipnc
  20. Fluid sim

    Hello all... I haven't used Houdini in a while, and I'm going through some old lessons from the cgworkshoips I had purchased but I'm running into a bit of a problem with the sim... I bring in unpacked geometry that's animated but when it collides with the flip fluid, the fluid gets deleted...but I can take a regular sphere, it will collide and appears to be no issues... I may have had this issue before, but I'm unsure how it was fixed or why it happens...can anyone take a look? Week3.hipnc
  21. Fluid sim

    I figured it out after 4 hours of troubleshooting... I deleted the velocity attribute off of the rocks...and that's what did it
  22. I wasn't quite suggesting adding velocity, what I was suggesting was a way to control velocity so you can direct where you want your sim to go.
  23. Ugly geo cleanup

    hello everyone I have a small problem... I'm trying to get my pyro sim to collide with my animated geometry that I fractured and well...solved in bullet. The pic is the mess to clean up and even when I turn it in to an SDF, laser scan on the staticobject and pyro still will not collide with this, but it has no problem with a regular box... So the question is, how do I clean up geometry from a bullet sim when I write it out?
×