Jump to content
jumper

how to mantra render with no camera motion blur?

Recommended Posts

Hi,

I have a scene with a deforming object and an animated camera. I would like to render only the deformation motion blur of the object with no camera motion blur. What is the best way of achieving this?

Thanks

Stephen

Share this post


Link to post
Share on other sites

I don't know if there is an easier way, but you can remove the values that a channel takes between integer frame numbers. For example, if you have an animation on channel ry then you can counteract for the interframe values with an expression in a parented null that corrects for the channel like so:

chf("../null1/ry",$FF+1)-chf("../null1/ry",$F)*1[/CODE]

Your camera will now move in jumps in that channel, from frame to frame, and therefore remove motionblur. You can even blend it in if you change the *1 value in the above expression.

Edited by Macha

Share this post


Link to post
Share on other sites

Install render parms on the cam - transform samples and set to 0

I just want to say, I have wanted to know how to do this for years! Thanks for that, Oslo!

-j

Share this post


Link to post
Share on other sites

Should just be Xform Time Samples yeah?

Render Properties -- Rendering -- Xform Time Samples.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, rbowden said:

Should just be Xform Time Samples yeah?

Render Properties -- Rendering -- Xform Time Samples.

Thanks!

 

For those following along, on the camera: Render Properties --> Mantra --> Rendering --> xform_motionsamples

Edited by LukeLetellier

Share this post


Link to post
Share on other sites

I'm doing some custom particle trails (taking into account the camera transforms) to do some more detailed motion blur effects. This means I don't want any blur on the particles (geo or camera).

However, I still need the holdout geo to have all of it's normal blurring. Anyone know if this is possible? Essentially, can you have camera blur on one object and not on another? I've tried all of the object specific render parms I can think of but no luck yet. Could just not be doing the right combination of settings.

Cheers, Carl.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×