Jump to content
DocWhite

mantra: Error writing data to image device

Recommended Posts

Hello everyone,

What it happens is weird. When I try to simply render the view with the default Mantra renderer or another Mantra node I get this error.

UT_NetPacket::write: No error
mantra: Error writing data to image device[/CODE]

Some people say that it is related to problems with the Firewall or the antivirus, I tried killing tasks and processes but I still get this error. However, if I re-start de program I can render perfectly all I want (sometimes, depending on the weather, yeah) and when a long time happens it outputs that error...

Any suggestions? Thanks for your attention.

post-10566-0-07363800-1382559010_thumb.p

post-10566-0-09956200-1382559014_thumb.p

Share this post


Link to post
Share on other sites

does it happen when you save render onto file as well or only with "ip"?

It does not happen when I render to an external file. Some people told me it could be MPlay.exe, it might not have enough privileges, or something like that, but I included an exception for it in my Firewall, it's complicated.

Share this post


Link to post
Share on other sites

i haven't used windows for few years but afair, you might have to run houdini as administrator. You have to include all local connections for sesintd, houdini, mplay and all sidefx tools for proper work as it uses local connections for communication in-between programs.

when you render to external file, mantra just creates file but when you render to IP, mantra opens up mplay and pushes image on the fly through the local connection so system have to give permission for that.

Edited by tmdag
  • Like 1

Share this post


Link to post
Share on other sites

i haven't used windows for few years but afair, you might have to run houdini as administrator. You have to include all local connections for sesintd, houdini, mplay and all sidefx tools for proper work as it uses local connections for communication in-between programs.

when you render to external file, mantra just creates file but when you render to IP, mantra opens up mplay and pushes image on the fly through the local connection so system have to give permission for that.

I tried for 5 minutes and it works fine if I run it as administrator. I will keep you updated about future crashes. I am not sure if it is due to that because sometimes (when I don't run it as admin) it works and sometimes it does not, let's discard possibilities.

Many thanks.

Share this post


Link to post
Share on other sites

Hi Artists!! I have some problems...The render view is generating scene and nothing happens... and mantra node tell me this. I have an apprentice license and i was rendering some chocolate last week with out any problems... Is the same problem but working in a mac and i dont know how to lunch as a administrator..

Captura de pantalla 2017-12-20 a las 21.30.43.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×