Jump to content
arkahtek

HELP!!! My smoke sim is blurry after rendering in 1080p

Recommended Posts

I figured .. Thanks for confirming that..what I may end up doing is getting the settings the way I want it..I'm investing In a Mac Pro sometime at the end of this year...I cloned an external drive, to use when I get the Mac Pro ..at present I have over 306 million voxels with a division size of 0.05 ..I'm simulating it right now ..it looks like I'll be posting a mantra frame in 3 months the way this render is going..lol ..I have 24 gigs of ram.

Edited by arkahtek

Share this post


Link to post
Share on other sites

If you want to test out OpenCL you can always boot into Windows, or Linux, on the Mac to run OpenCL. Bootcamp will make it very easy to share the files across to the Mac once simulated.  

Edited by marty

Share this post


Link to post
Share on other sites

Cool  Thx marty, i never did bootcamp before. YES I can definitely try that..can you tell me some things to expect like quirks..or limitations of running Houdini in bootcamp?

Share this post


Link to post
Share on other sites

It's all positive, Houdini runs better in Windows than OsX currently, memory does seem to get fragmented for larger fluid sims though I hear.

 

For Bootcamp - print out the installation instructions, as you need them, or they are very useful to have next to you.  The only small thing is to install the latest graphics card drivers in Windows. On OsX they are built into the system.

 

I'm not too sure about your graphics card though, it may be too small to be able to do too much!  But you can always run OpenCL on the CPU by setting an environmental variable.

Edited by marty

Share this post


Link to post
Share on other sites

Wow..that's awesome.. Thanks Marty..I'm on it now ..yes this graphics card is definitely a no-go for these types of sims..but open cl can definetely help here..

Share this post


Link to post
Share on other sites

I'm not too sure about your graphics card though, it may be too small to be able to do too much!  But you can always run OpenCL on the CPU by setting an environmental variable.

 

 

 

I never did get this working on Windows. I should get around to setting it up on Linux at some point.

Share this post


Link to post
Share on other sites

Ok cool got it..so basically these are the drivers I have to download to get houdini to work in windows via boot camp?

 

No - Houdini will work fine without this driver - this is specific to running OpenCL on the CPU - OpenCl can be highly efficient, though I hear the reality is that C++ can be optimised to the same level. 

Share this post


Link to post
Share on other sites

OpenCL support is a great feature but don't kill yourself over it. open cl does speed up the sim by 25 - 35% but I haven't been able to use it in all situations and here's why. First off, open cl simulations on the graphics card will limit you to the number of ram you have on the gpu itself, so if you only have 3gb of ram on your gpu 3gb is all you can use even if your machine has 128gb of system ram. You can also have your motherboard share ram with the gpu but this creates an I/O bottleneck. Additionally you would need to use dedicated and powerful gpu's with lots of cores and lots of ram to even notice a performance boost compared to pure cpu processing. 

Share this post


Link to post
Share on other sites

Just to clarify, opencl works fine on the video card, it would not work on CPU for me. I tried everything I could think of with the Intel driver, it just wouldn't work.

 

 

Bummer - I thought I had this working - no Windows here currently to retest with - what really helped Window's OpenCL CPU was the experimental driver:

 

http://www.sidefx.com/docs/houdini13.0/news/13/opencl

Share this post


Link to post
Share on other sites

Did it work at all on CPU? Intel isn't necessary, it's just optimised. This should work*

 

export HOUDINI_OCL_DEVICETYPE = 'CPU'

 

*Can't test currently 

Share this post


Link to post
Share on other sites

No, it didn't work. -- OpenCL would fail inside of Houdini for me. Iirc it could not find "OpenCL device CPU"   (something along those lines), and I had the intel driver installed, and it was in the system env paths.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×