Jump to content
Sign in to follow this  
konstantin magnus

Color baking issue from high-poly to low-poly

Recommended Posts

I am trying to bake point colors from a high poly-model to a low poly-model using the gather loop within a surface shader.

 

post-10570-0-68228500-1423849669_thumb.j

 
While my baking shader for cavity (left) and normals (center) shows all the details, the surface color baking does not work as well (image on the right).
 
post-10570-0-95544900-1423849721_thumb.j
 
In this case all the grout and gaps are missing: 
 
post-10570-0-52062300-1423849754_thumb.j
 
I attached the hip file. Any ideas how to solve this issue?

pillar_sculpted.hipnc

Share this post


Link to post
Share on other sites

Hi!
Rayhit vop use a lenght of "dist vector" as a maximum distance from sample point to target geo point, so seems you need to try mult your dist vector to value, in which distance your want to gather detail form hipoly geo.

 

ps your scene is too much for my laptop, i cant compute all hipoly geo, so is only my surmise

pps sorry for english

Edited by _dv

Share this post


Link to post
Share on other sites

thank you for creating the file!

 

the result looks like another normal map to me though.

 

post-10570-0-88514500-1424290236_thumb.j

 

however i am looking for a way to gather the surface color from a high poly object and map that *diffuse* map to a low poly object! sorry for the inconvenience : (

Edited by konstantin magnus

Share this post


Link to post
Share on other sites

well it is a normal map probably.
but extracting the normal or the colour is effectively the same thing
just instead of querying the N vectore 3 you query the Cd vector 3.
swap the attribname and done.

Share this post


Link to post
Share on other sites

however i am looking for a way to gather the surface color from a high poly object and map that *diffuse* map to a low poly object! sorry for the inconvenience : (

 

in attached scene, at the /obj/geo1/objnet1/shopnet1/vopmaterial1 is switcher named color/normal,

it must be turned off for baking color

 

Edited by _dv

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×