Jump to content
blendingshadow

moving particle in one axis with noise

Recommended Posts

Hey,

 

I am trying to generate points on a surface via a colour attribute.

 

Then using gravity at the end of the pop net, apply noise as they move down or across the surface. I seem to get stuck with the noise. If I add it, they stop becoming stuck to the surface and start spraying away.

 

Any idea how I could fix that?

 

Thanks

Edited by blendingshadow

Share this post


Link to post
Share on other sites

I am trying to get blood bleeding into cloth, the colour information at the very least.

 

Using a point cloud gave me 'honey combing' which doesn't look right.

 

I had intended to emit from the surface and have the points stick there. Then do a trail, resample, colour and then attribute transfer.

 

The attribute transfer gives nice blend thresholding.

 

That was my thought process, if there's a better way then I would be happy to learn something new :)

Share this post


Link to post
Share on other sites

Had a look at the Ray Node and it does the trick nicely.

 

I have attached a crude file that demonstrates the technique.

 

I have basically created a grid with colour and a pop location. I create a trail based on frame and then use an add with the 'id' attribute. 

 

I then apply a colour, ray it to the surface and do a colour transfer. 

 

To get it to 'blur' become diffuse I animate the blend threshold over the frame and use a large division.

 

Thanks for helping me get there.

 

Next step to look at using the sop solver to work out how to make it 'blur' at different rates rather than all at once

bleed_pop.hip

Edited by blendingshadow

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×