Jump to content
borisb2

flip whitewater source

Recommended Posts

I'm setting up a new flip sim - open ocean shot.

 

main flip sim so far looks good.

 

But whitewater source is causing problems. When using "volumes and particles" as source I get nothing with vorticity, When using "Particles only" I get this: (see image)

 

Also trying acceleration or curvature gives not one good source for foam emission - didnt have that before

 

any idea whats causing this?

 

post-4280-0-24948300-1437512748_thumb.jp

Edited by borisb2

Share this post


Link to post
Share on other sites

no, its the wavelayer setup with some customized velocities (around the boat). Seems like this is happening only on this cache - a different cache-version doesnt show that behavior.

As mentioned, also acceleration and curvature are showing weird results (stretched)

Share this post


Link to post
Share on other sites

Anyone else having the same issue as this? 

Getting similar results from sims using Guided Ocean Layer and not getting very nice source for whitewater.  Any fixes to get round this at all?

Share this post


Link to post
Share on other sites
On 09.02.2018 at 2:16 PM, djwarder said:

Anyone else having the same issue as this? 

Getting similar results from sims using Guided Ocean Layer and not getting very nice source for whitewater.  Any fixes to get round this at all?

What do you mean "not getting nice source for whitewater"? Can you show the picture?

Share this post


Link to post
Share on other sites

Never get this. Do you use shelf tool for creating sim? Try to disable all custom stuff and check if you get this.

Share this post


Link to post
Share on other sites

as far as I remember it was because of droplet-attribute which I was using .. disabling it fixed that issue.. but this was way back with H14 I believe

Share this post


Link to post
Share on other sites
On 12/02/2018 at 8:25 AM, tamagochy said:

What do you mean "not getting nice source for whitewater"? Can you show the picture?

Seem to be getting lots of pockets of velocity under the surface and also around edges.  Makes sourcing nice whitewater emission pretty tricky!

This screenshot shows a bit of the issues - side view of a ww source from a flipsim (guided ocean layer) with a collider on surface and then saved out via fluidcompress ...

 

wwsrcfail.jpg

Edited by djwarder
Massive image!

Share this post


Link to post
Share on other sites

you can easily creat your own emission criteria. No need to use shitty houdini-one.

Just sample in a VOP neighbor velocities, subtract from current points velocity and fit range length of that vector into emission criteria. Remove all points that dont meet emission criteria . thats just one way

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×