Jump to content
b16tran

How to get motion blur on geometry imported from Maya Alembic?

Recommended Posts

Hi,

 

I exported an animation out of Maya using Alembic and imported it into Houdini. I do not see an option to turn on geometry motion blur anywhere. I have tried putting down a trail SOP and timeblend SOP after the Alembic SOP but still get nothing.

 

Any ideas? If anyone has solved this or have a better way of getting animated geometry from Maya into Houdini please let me know.

 

Thanks!

Share this post


Link to post
Share on other sites

Hi,

 

you should not need to do anything to your animation to get geometry motion blur. Just enable it on Mantra node and give it at least 2 geometry samples. in case you want to render motion substeps (or xform motion blur) you have to use an alembic archive (not just alembic object).

Share this post


Link to post
Share on other sites

Make sure you unpack your geometry with an unpack sop before calculating the velocity with the trail sop. By default the Alembic sop imports the geometry as delayed load primitives, but ignore this if you are importing it as Houdini geometry. You also have to turn on Geometry velocity blur in the sampling tab of your geometry object and finally enable it in your Mantra node ("Allow motion blur" in the Rendering tab).

Share this post


Link to post
Share on other sites

I did have it switched to Load Houdini Geometry (Alembic Archive). I couldn't find a sampling tab to enable xform motion blur. It is setup correctly for mantra settings, since I do have other objects in the scene rendering with motion blur.

Share this post


Link to post
Share on other sites

Hey Brian, I'm not sure where to turn on motion blur on the Alembic Archive, what I would do is create a new Geometry node at object level and just do an Object Merge and bring in the geometry from the Alembic Archive (You might want to import the objects transformation also if you have any transformations applied at object level). The enable Geometry velocity blur option is on the sampling tab of the geometry object you created. 

Edited by Jero3d

Share this post


Link to post
Share on other sites

No problem! If you want to keep everything inside one node you can use the Alembic sop to import your alembic geometry for every object. Im gonna look into other options only using the Alembic Archive and post if I find anything useful.

Share this post


Link to post
Share on other sites

you need to go to your geometry level and in property>render>check geometry velocity blur 

Use trail SOP with compute velocity and angular velocity.

In mantra check motion blur and use geometry sample at least 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×