Jump to content
90okm

thin-walled container in flip simulation

Recommended Posts

Hi ! 

I've just started creating effect of falling barrel.

As the barrel falls all of its containment is being spilled out.

The problem is that i can not use thicker walls in barrel because the liquid must flood area under fallen barrel. 

So i have to set up a thin-walled container, but in this case i faced the problem with flip leaking through barrel walls.

Another one issue is the number of flip particles. a lot of them just dissapear ! The quantity of flip particles at the end of sim is much lesser than at the beginning (reseeding is on)

How to cope with this issues ? I've tried to raise substeping parameter / collision resolution ... but still can not get appropriate results

Pleas take a look at the attached file ! in this case you may notice particles penetrating the barrel around frame 35

Maybe some of you can suggest a hint how to prevent particles penetration/loosing?

or the only thing i have at my disposal is raising substep parameter to some incredible values ?

Thanks in advance !  

  

b1.hip

Share this post


Link to post
Share on other sites

hey you have been on the right path. 

look at the hipfile. ive changed the collision methond in the solver to particle and used the static solver. in my experience this works better than than just pump in collision fields into the sim. now the collision is a seperate dop object.
dialed down the substeps to 1 and let the solver decide when its needed. could be that you need more later when the fluid starts to splash. didi not sim that long. but at least you dont have any loss at the beginning 

good luck!

b2.hip

 

edit: you could do the volume sample method in the static solver and use vdbs. 

Edited by sekow

Share this post


Link to post
Share on other sites

Thank you for quick response....but the problem is still on.

1) The situation is getting better but there is a lot things to fix

particles still go through container walls 

 

leack.png

2) I've measured the volume of particle fluid at the beginning and at the end of sim....

according to geometry spreadsheet - the volume of fluid at frame 35 three times lesser than at the first frame. 

the two-thirds part of fluid just goes away.... and it's not leaking... it seems like the solver just removes some particles out of simulation. 

begin.png

end.png

Edited by 90okm

Share this post


Link to post
Share on other sites

For best results you might want to use VDB proxy for collision. Also check collision visualisation in FLIP object node, if there is stepping with holes, it's resolution related (collision, flip or both).

Share this post


Link to post
Share on other sites
5 minutes ago, sasho78 said:

For best results you might want to use VDB proxy for collision. Also check collision visualisation in FLIP object node, if there is stepping with holes, it's resolution related (collision, flip or both).

Yes ! This is the very first thing i check before starting any simulation ! and collision surface seems to be ok ! I have even raised the resolution more than enough !

 actually .... as far as i've noticed this is the common problem when you lose flip fluid volume , nevermind if you even have the constant quantity of particles itself

Share this post


Link to post
Share on other sites

Hey Sekow,

Here is a working solution but its a bit on the slow side: video test

I also changed your collision object to the static object method with volume sample. The way you were doing it directly updates the velocity field and can easily get unstable and error a lot. FLIP really isn't made for very thin colliders but with the changed settings and cranking up the substeps I got it to work.

Another simply cheap that would run faster would be to animate an extrusion. So that the collision object only gets thin once the spill happens.

Cheers,

Zybrand

b1_zj.hip

Share this post


Link to post
Share on other sites
2 hours ago, Zybrand said:

Hey Sekow,

Here is a working solution but its a bit on the slow side: video test

I also changed your collision object to the static object method with volume sample. The way you were doing it directly updates the velocity field and can easily get unstable and error a lot. FLIP really isn't made for very thin colliders but with the changed settings and cranking up the substeps I got it to work.

Another simply cheap that would run faster would be to animate an extrusion. So that the collision object only gets thin once the spill happens.

Cheers,

Zybrand

b1_zj.hip

Great ! Thank You for precious advices 

it works well ! 

  • Like 1

Share this post


Link to post
Share on other sites

while we are at it. Ive never understood that proxy thing. When we volume sample vdbs from sops, isnt that redundant? In the end dops transfer the sdf into a dop object out of houdini volumes. 

Share this post


Link to post
Share on other sites

Someone correct me if I am wrong but the reason for the vdb proxy from sops is because vdb is no currently supported in dops but it still creates a better collision sdf than ray intersect with less errors and faster. Calculating the vdb in sops and converting it in dops is faster and more efficient that calculating the collision volume in dops especially if the vdb is cached as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×