Jump to content

Recommended Posts

Creating a node takes ages. What could be the problem that is making it so slow? It did this after the latest update (updated 15.5.632 to 15.5.674)

Please note that we already tried to install versions as far back as 15.0 and until the latest version of 15.5. The problem keeps occurring even without virus scanners and windows defender being turned off. It also doesn't matter if it is installed on a SDD or on a HDD and all the drivers are up to date. Even if all the preferences have been deleted (in the documents directory) it stays the same and it also doesn't matter on which Houdini License server it's running: in Standalone mode or not. I'm running out of ideas to what the problem could be. If you know the solution or have an idea what it could be, let me know!

Please ignore the audio in the example video below, it is in a noisy classroom with students discussing different nodes (not related to what you see, you can watch without audio)


 

Edited by ivovanroy

Share this post


Link to post
Share on other sites

Yeah, that sucks. I am going to wildly guess that you have some kind of conflict with those other development environments like unreal or unity etc.. What you really should take a picture of is the Task Manager. What kind of CPU usage do you see? Is there network traffic happening..? What is memory usage like?

Also post your machine specs. Your machine does meet the hardware requirements, right?

I'll just offer up the Microsoft advice. Completely blank your machine and only install Houdini and conduct your GEO node test. Then add your additional software one at a time launching Houdini after each installation till you discover where the conflict lies. I also use OBS, Chrome and Adobe and I have no Houdini issues so maybe you can rule those out as conflict candidates. Is that a Canon Scanner software icon I see?

Try typing "msconfig" in the Windows Start area. This will bring up a tool that will allow you modify what gets loaded on startup. Maybe you can avoid a complete rebuild by modifying the startup software?

Edited by Atom

Share this post


Link to post
Share on other sites
14 minutes ago, Atom said:

Yeah, that sucks. I am going to wildly guess that you have some kind of conflict with those other development environments like unreal or unity etc.. What you really should take a picture of is the Task Manager. What kind of CPU usage do you see? Is there network traffic happening..? What is memory usage like?

Also post your machine specs. Your machine does meet the hardware requirements, right?

I'll just offer up the Microsoft advice. Completely blank your machine and only install Houdini and conduct your GEO node test. Then add your additional software one at a time launching Houdini after each installation till you discover where the conflict lies. I also use OBS, Chrome and Adobe and I have no Houdini issues so maybe you can rule those out as conflict candidates. Is that a Canon Scanner software icon I see?

Try typing "msconfig" in the Windows Start area. This will bring up a tool that will allow you modify what gets loaded on startup. Maybe you can avoid a complete rebuild by modifying the startup software?

Thanks for the quick reply. Sadly it's not like that. There is no conflict with other development environments (as far as that we tested/know of) CPU and everything stays fairly the same, nothing incredible or strange happening there either. 

My machine has the following specs: 
Edition: Windows 10 Edu
Version: 1607
Processor: Intel(R) Core(TM i7-4720HQ CPU @ 2.60GHz
RAM: 16GB (15,9 GB usable)
System Type: 64-bit operating system, x64-based processor 
GeForce GTX 960M: Driver version 379.17

Strangest part is that it was working before hand. It worked until a week ago and I only updated Houdini itself. The rest is still the old system.

Share this post


Link to post
Share on other sites

Hey guys,

The same problem happened with me lately. This might be a Windows 10 issue, because H15 and H16 does the same thing. And it was working for me as well before.

Any node I try to place in a totally empty scene, it takes forever to Evaluate Python and run Hscript command.

Did you find any solutions by any chance?

Any help would be greatly appreciated!

 

Thanks in advance,

Laszlo

Share this post


Link to post
Share on other sites

Hey,

Just check that it isn't a locale problem - check out this thread and see if it helps:

Matt.

Share this post


Link to post
Share on other sites

Hey Matt,

Thanks for your reply. Unfortunately it's not a locale problem, or at least I don't think it is. My Windows 10 is set to US English language and the location is US as well.
And as I said, it worked like 2 weeks ago. First I thought it's H16, because that's the only new thing I remember installing with my setup since it started misbehaving. And after that my H15 started acting the same way as well.

It's a pretty weird issue, since when I try to create a Grid for example, if I click on the shelf tool, it creates the grid without any problems. But when I try to lay down a Grid node on my network view that's when it starts loading and loading.
And like 10 to 15 minutes later the grid node appears. And Houdini is not even crashing, it just starts cooking and the timer shows the elapsed time correctly in the bottom left corner.

Such a weird thing, I will try to reinstall my entire operating system, and maybe will go back to Win7. :)

At work we are using Ubuntu Linux and didn't have this kind of issue at all...

So no clue what could be the causing problem of this weird phenomena.

 

Thanks again for trying to help and taking the time to reply.

 

Share this post


Link to post
Share on other sites

Hey guys! After diving into all the possibilities, I found out the problem. It's actually an easy fix, with no need to reinstall any programs. Just do the following:

Go to your device manager (you can find this if you type in Device Manager in the start search bar). Find the Display adapters and look for the Graphic cards. If you're having the exact problem I was having in the first posted comment, then you are most likely working with an NVIDIA GeForce GTX 9-something series. Click that card with the right mouse button and go to the properties. Click the "driver" tab in the newly opened window. It will give you multiple options, among one called Roll Back Driver. Click that and when asking the reason you're doing the rollback, submit that your current software isn't working with it. It wil reset the settings for Houdini and this might actually take a minute or so. After this you should no longer have any problems with it. Sorry for my late reply, but I only found it out 3 weeks ago.

Best regards!

Share this post


Link to post
Share on other sites

Wow Ivovanroy!

That actually did the trick! So that freaking NVidia driver was causing this issue all along... I would have never guessed this, because it really didn't seem like an actual video card problem.

So thank you so much for taking the time to let us know the solution!
I'm glad I didn't have to reinstall my entire windows OS. :D

Thanks a lot again! ;)

 

Share this post


Link to post
Share on other sites

You're welcome mate! Funny enough is that I send my pc to the manufacturer because I thought it was a hardware problem. After that I still had the problem (obviously) and I reinstalled my os. After that a lot of 1st years at my school had the same problem and I actually realised where the problem was haha. Made me feel really stupid about what I had done in advance! Anyways, glad that I could be of service!

Share this post


Link to post
Share on other sites

I was having the same problem (and it doesn't at all look display related) and I rolled back my Nvidia driver and the problem is now cured.   the problem is that I don't recall ever updating my Nvidia driver unless windows 10 is doing it automatically and it's strange because the problem doesn't look graphics related.  Here is the current version of the driver I am using (the one I rolled back to):

10.18.13.5930

I am wondering if SideFX knows about this ?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×