Jump to content
violalyu

Crowd popsteerobstacle with concave shape obstacles

Recommended Posts

violalyu    5

Hi Houdini friends!

Has anyone tried doing crowd simulation with concave shaped obstacles? (e.g., crowds coming from a train carriage to the platform, where the obstacles are the hull of the train carriage) I tried to use SOP and DOP data on the popsteerobstacle, both of them didn't work well, agents were still going through the hull of the carriage.  Does anyone have a clue how to fix this? Thanks a lot!!!

Best,

Viola Lyu

Share this post


Link to post
Share on other sites
edward    331

Concavity shouldn't matter I would think since most of the agent collisions are done with ray tracing. Are the agents going completely through or just a little bit? If it's the former, then maybe you need to increase the collision sampling. If it's the latter, then maybe the radius on the agents need to be bigger.

Share this post


Link to post
Share on other sites
violalyu    5
On 1/14/2017 at 0:42 AM, edward said:

Concavity shouldn't matter I would think since most of the agent collisions are done with ray tracing. Are the agents going completely through or just a little bit? If it's the former, then maybe you need to increase the collision sampling. If it's the latter, then maybe the radius on the agents need to be bigger.

Thanks edward! They are going completely through, I'll try and increase the collision sampling and see if it works! Thanks a lot!!!

Share this post


Link to post
Share on other sites
violalyu    5
On 1/14/2017 at 0:42 AM, edward said:

...If it's the former, then maybe you need to increase the collision sampling. ...

Sorry to ask you a silly question, I tried to find collision sampling controls on crowd object, crowd source and crowd solver, and agent and agent prep, and I didn't find it. Could you please tell me where that is ... Thank you very much!!!

Share this post


Link to post
Share on other sites
violalyu    5

@Atom
@edward

I tried to increase the sample and the far / near force, and it doesn't change the agent behaviour, if you have time could you please check this file? Probably I did something wrong with the setup... the crowd sim dopnet is in the sceneMain geo obj where the sticky red note is, thank you very much!!!

crowdTest.tar.gz

Share this post


Link to post
Share on other sites
Atom    516

In this situation you may be better off using goals rather than blindly traveling along the X axis with a velocity of 1.

If you have not watched Peter Quints tutorial on crowds, check it out. He demonstrates how to solve for a scenario very similar to your case.

 

Share this post


Link to post
Share on other sites
violalyu    5
25 minutes ago, Atom said:

In this situation you may be better off using goals rather than blindly traveling along the X axis with a velocity of 1.

If you have not watched Peter Quints tutorial on crowds, check it out. He demonstrates how to solve for a scenario very similar to your case.

 

I've watched it just now, it seems promising! I'll try and see if it works for my situation! Thanks a lot!!!

Share this post


Link to post
Share on other sites
violalyu    5

@Atom I tried with a basic setup where I only have obstacles and I break them into convex pieces so it shouldn't be related with concave shapes and such, but the popsteerobstacles doesn't seem to work either... Am I setting up something wrong? Thanks a lot!! Here's the new scene.

crowdTestNew.tar.gz

Share this post


Link to post
Share on other sites
edward    331

Ah, I keep forgetting about this in crowds. Since the obstacle rays are sent from the agent particle, they're missing the obstacles because they both start right at the y=0 position. If you look at the bottom of the Street Crowds Example obstacles, they buildings are carefully extended below ground level to avoid this problem.

 

Capture.PNG

Share this post


Link to post
Share on other sites
violalyu    5

@edward

It didn't work for me... Interesting enough, now the agents begin to penetrate with each other, it seems there's no collision at all... I checked the agents, they are will the default collision layer, is there a setting that I missed in the crowd sim? Thanks a lot!!!!

Share this post


Link to post
Share on other sites
violalyu    5

Okay, so this is what I assume could be the problem... I checked on the avoidance geometry guide, and it was showing me the spheres, instead of the pre-prepared collision layer that sidefx provided with this mocapbiped3, could that be a problem? Is there a way to bring the collision layer in or some specific settings that need to be checked, or this is defaulted to be computing using the collision layer already?

Screenshot.png

Share this post


Link to post
Share on other sites
violalyu    5

Besides, I noticed the shelf provided street scene by sidefx has the same problem, and after about 20 frames there are agents going through the obstacles too... @edward I guess this is an issue for using the popsteerobstacles ...

Share this post


Link to post
Share on other sites
violalyu    5

Updates!

So I reported this to sideFX and their support team helped me fix this! Here is the new file if anyone wants to reference. Here's the main solution for the problem, quoting the email:

"Decreasing the particle scale multiplier to e.g. 0.3 will help a lot for the agents that start next to the obstacle. Otherwise, there isn't much room for them to anticipate and avoid the collision. Similarly, lowering the Min Speed parameter for orientation updates and increasing the Max Turn Rate also helps for those agents
 - Switching the path force for a seek force works a bit better for guiding the agents to the right side of the obstacle."

 

Cheers!

 

P.S. @Atom @edward Thanks for your help!!!

basicCrowd_v004_sidefx.hipnc

Share this post


Link to post
Share on other sites
Atom    516

Gald you worked it out. It makes sense that a lower scale multiplier would improve accuracy. Essentially giving it more time to sample what needs to be done. I am surprised that increase max turn rate would help. I would have assumed the opposite. A slower turn time also means more time to evaluate what needs to be done. But I guess lowering the min rate achieves that too.

 

Thanks for posting the updated file!

 

Share this post


Link to post
Share on other sites
cwhite    45
3 hours ago, Atom said:

Gald you worked it out. It makes sense that a lower scale multiplier would improve accuracy. Essentially giving it more time to sample what needs to be done. I am surprised that increase max turn rate would help. I would have assumed the opposite. A slower turn time also means more time to evaluate what needs to be done. But I guess lowering the min rate achieves that too.

 

Thanks for posting the updated file!

 

For this setup, where the agents start out very close to the obstacle and are walking toward it, having a low max turn rate means that the obstacle avoidance force can't change their direction quickly enough before they hit the obstacle. An alternative, though, is to adjust the allowed speed variance so that the obstacle force can slow the agents down somewhat as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×