Jump to content
Sign in to follow this  
Atom

Static Proxy Volume Excessively Evaluates?

Recommended Posts

Hi All,

I have a FLIP scene with a single static object collider.  I have prepared a VDB version to supply as the Proxy Volume for the Static Object. When I populate the proxy volume field Houdini goes off into la-la land running a single core process, I assume to generate the proxy volume for FLIP collision. Eventually my collision object appears in the viewport and looks ok. So I click play and once again Houdini drops down into single core process mode and takes forever to crank out a FLIP frame, but it works. I think, ok I guess the solver had to generate the proxy volume at the start of a new simulation. So I wait again and the solver moves on to the next frame.

The same thing happens again, a slow single core process to convert the proxy volume. I might expect this kind of operation if I were supplying a deforming geometric collision object my object is static and that checkbox is off by default.

I put a switch on the static solver to illustrate the point. If I switch off collision the sim immediately jumps into multi-core simulation mode and moves along at a good pace.

Is this bug, do proxy volumes evaluate every frame for static geometry?

ap_cmf_excessive_proxy_volume_update.hiplc

Untitled-1.jpg

Edited by Atom

Share this post


Link to post
Share on other sites

You need to check off collision guide if you want to run the simulation in the viewport. When you have Collision Guide turned on, houdini calculates that mesh you are seeing in the viewport per frame. I DLed your file and turned that off and everything seems to play fine (after putting the switch you have in there back to 0).

Edited by rbowden
  • Like 1

Share this post


Link to post
Share on other sites
35 minutes ago, Atom said:

Is this bug

I'm not quite sure you have realised but you can dive into the Static Object and check out the setup? The whole purpose of Houdini over something blackbox like, like Maya, is that you can modify and learn from when has been setup.  The default position of 'is this a bug' to anything that doesn't work as you expect it to is almost the antithesis of why people use Houdini IMO.

It's like using a tutorial in C++ and then saying, hey when I use this tutorial in my program and it doesn't work, is there a bug in C++...

Share this post


Link to post
Share on other sites

Turn on perfomance monitor, check what takes up the time. Easy way to pinpoint problems. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×