Jump to content
AntoineSfx

Linux UI problems

Recommended Posts

I'm evaluating 15.5 under Linux Mint and there are all sort of problems.

Handles by default are incredibly small but this can be changed in Preferences, even though it should be by default at a reasonable size.

Cameras won't work. By default it seems to create orthographic ones, but they are impossible to use; it throws a great amount of stack error, (references to near and far planes I believe)

FEM doesn't work. it stops at 25% of tetrahedralize step, never to finish. A simple cube should takes a fraction of a second under Windows, so I guess he's stuck in a loop somewhere.

Middle mouse button doesn't work. It's doing random things like setting a keyframe, setting nan, random values, and so on.

I couldn't even try Mantra because cameras are impossible to set up.

Right now I have a feeling Houdini under Linux is so broken. Do you use Linux, and which distribution are you using (assuming you don't have any of the aforementioned problems).

Share this post


Link to post
Share on other sites

I've used Houdini on Linux for almost a decade. It wouldn't surprise me if most Houdini customers were using it on Linux. Most of the time I've been using Ubuntu and sometimes Fedora and CentOS. Are you using a high DPI display like UHD or a Mac with a Retina screen? Have you used Houdini on other platforms or is this your first time using Houdini? Are you using the graphics drivers from the manufacturer or the open source drivers?

Share this post


Link to post
Share on other sites
35 minutes ago, lukeiamyourfather said:

I've used Houdini on Linux for almost a decade. It wouldn't surprise me if most Houdini customers were using it on Linux. Most of the time I've been using Ubuntu and sometimes Fedora and CentOS. Are you using a high DPI display like UHD or a Mac with a Retina screen? Have you used Houdini on other platforms or is this your first time using Houdini? Are you using the graphics drivers from the manufacturer or the open source drivers?

No high DPI display (a good size Iiyama 2560 x 1440 but nothing really special)

The driver is the one provided with a Mint package, so this is the manufacturer driver (most recent I could install). I've been using Houdini for a few weeks on Windows on the same computer, but I can't work without a proper shell and Unix tools, so I need to go back to Linux (which I'm using since the late 90's). I'm comfortable with the Houdini UI, I actually like it. I've been using it daily under Windows. I actually have lots of errors in the camera nodes, so this is not an instance of PEBKAC.  I left Ubuntu when they switched to Unity and spent some time under OS X but I bought this workstation (HP Z820, dual E5-2670 with 64 GiB of RAM and a NVidia 980 Ti) with the intent to do some rendering on it, preferably with Houdini under Linux.. I will try other distributions tomorrow.

Share this post


Link to post
Share on other sites

I am using Houdini on MInt 18.1 with no problems at all, in fact, the performance is fantastic!
I would recommend installing the display drivers manually, especially if you have an nVidia card as the default drivers are, quite frankly, crap.

I use a dual monitor setup with a gtx1060, 6GB card and it runs flawlessly.

Hope you get it sorted!
Matt.

Share this post


Link to post
Share on other sites

I am also using it with Linux for years without problems, and I think it works best with Linux. How did you install it, maybe some permission problems? Can you start it with terminal and let us know are there some  error messages spit by H?

Share this post


Link to post
Share on other sites

Yeah I moved to Mint 18 as well, from Mint 17; this is how I switch to the Nvidia drivers: 

  • Settings > Driver Manager
  • Pick one of the proprietary Nvidia ones; currently I see and use nvidia-367 (I use a 1060GTX)
    • As more LTS releases come along, this list will grow; Mint 17.3 had several
  • Hit Apply Changes, and reboot your machine

screenshot-window-2017-02-18-095313.png

 

 

Share this post


Link to post
Share on other sites

So I had a similar problem. Basically cameras near plane 0'd out. Vex not working, etc, etc.

Its a locale problem. Houdini is evaluating floats "." and replacing with "," (commas), which throws all kind of problems. Simplest way to workaround this is to start Houdini in a shell with the command;

LC_ALL=C /opt/hfs15.xxx/bin/houdinifx

As I understand it, this forces all the local settings for that app to default English.

Worked for me under Ubuntu 16.04

Good Luck, R

 

Share this post


Link to post
Share on other sites
On 18/02/2017 at 5:21 PM, jiggymoon said:

 

 

So this was actually a locale problem. After carefully reading the errors messages, it appears that during the installation (I couldn't find them in the .tar.gz) some files are created using the locale for the formatting, hence problems... For example a UI definition file contained  range(0,001,10) instead range(0.001, 10) which is a syntax error in the DSL used in that file, and the rest of the file is dropped.. I'm glad it was nothing, I ordered a proper us-eng keyboard, which is also a great programming tool.

 

Share this post


Link to post
Share on other sites

Also having problems with using alt-"any command" on linux ubuntu 16.04 LTS. I'm unable to create dots, set keyframes, split panes etc. If anyone knows what might be going on here I'd appreciate the help! Not experiencing the issues AntoineSFX is except for these though.

Share this post


Link to post
Share on other sites
51 minutes ago, trzanko said:

Also having problems with using alt-"any command" on linux ubuntu 16.04 LTS.

By default most Linux distributions use the Alt key plus clicking as a shortcut for dragging a window without having to click the title bar of the window.

http://askubuntu.com/questions/118151/how-do-i-disable-window-move-with-alt-left-mouse-button-in-gnome-shell

I use GNOME and that's how to fix it in GNOME.

Share this post


Link to post
Share on other sites
15 minutes ago, lukeiamyourfather said:

By default most Linux distributions use the Alt key plus clicking as a shortcut for dragging a window without having to click the title bar of the window.

http://askubuntu.com/questions/118151/how-do-i-disable-window-move-with-alt-left-mouse-button-in-gnome-shell

I use GNOME and that's how to fix it in GNOME.

Ah, thank you. I'll look in to this as a solve.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×