Jump to content
gramx

Houdini to Unreal - Vertex Animation Textures

Recommended Posts

Lil update for anyone interested - I got sprites to work by turning on two sided which made them visible and fixed the issues :) (within the UE4 Shader)

Edited by chrisdunham95

Share this post


Link to post
Share on other sites
9 hours ago, chrisdunham95 said:

Lil update for anyone interested - I got sprites to work by turning on two sided which made them visible and fixed the issues :) (within the UE4 Shader)

I often have to flip normals when exporting from Houdini.  Could probably fix that prior to export if double sided is undesirable.  One thing that helped me find this prior to export is in the display options, under optimize, flag the remove backfaces option.    But it also could just be an issue in the export rop.  Good find!   

The fluids issue is strange.  I'll run through the fluids tomorrow and see if I can figure out the magic settings.  I realized last night after I posted that what I thought of as my "fluid" is actually not a fluid export but a soft body export.  The simulation is fluid, but I use that to displace the original mesh since I was just doing some melting stuff.  So it is possible I never did figure out the fluid end.  I'll dig around though and see if I can find anything useful.  Oh, random thought, you could double check the import settings on the texture to see if it is set to Vector Displacement instead of a standard compressed file.   

Edited by LucidMovement

Share this post


Link to post
Share on other sites
18 hours ago, LucidMovement said:

I often have to flip normals when exporting from Houdini.  Could probably fix that prior to export if double sided is undesirable.  One thing that helped me find this prior to export is in the display options, under optimize, flag the remove backfaces option.    But it also could just be an issue in the export rop.  Good find!   

The fluids issue is strange.  I'll run through the fluids tomorrow and see if I can figure out the magic settings.  I realized last night after I posted that what I thought of as my "fluid" is actually not a fluid export but a soft body export.  The simulation is fluid, but I use that to displace the original mesh since I was just doing some melting stuff.  So it is possible I never did figure out the fluid end.  I'll dig around though and see if I can find anything useful.  Oh, random thought, you could double check the import settings on the texture to see if it is set to Vector Displacement instead of a standard compressed file.   

Ahhh yes good thought!

Ahhhhh strange that a fluid works through the soft body export but I will give that a try myself and see the results, yeah again nice thought I will keep it in mind but most of the time textures seem to recognise correctly,  Thanks again Neil :)

 

- Little update; tried the soft body method with a small moving fluid but couldn't get the translation to work, sooo went back to the fluid method but still getting the exact same look (almost asif the position map is baked with higher polycount/vertex count than the fbx I import and so cannot move all verts correctly but the movement is roughly correct)

- Another thought, Has anyone found it necessary to manually set the bounding box parameters (min/max) within the UE4 shader? thought it maybe fix some issues but perhaps a hopeful but simple solution

 

Please see the issues with my fluids inside UE4 in the video below

2017-10-11_Capture_Fluid_Mesh_Issues.flv

Edited by chrisdunham95
Adding attatchments

Share this post


Link to post
Share on other sites

Found a solution to my above issue - my frame range in the shader was off by 1 due to a bit of personal error! So fluids working :) - and for anyone having RBD issues make sure fully precisions uv's are turned on and the filter inside the mesh I believe should be set to nearest which should help

Share this post


Link to post
Share on other sites

Oh, wow.  Useful info, didn't know it would fail in that way with the frame being off.  Good to know!   The bounding box min/max I've always had to set.  The UE4 shaders they give you to copy I think are just generics.  Once you have one in your project you can just make material instances and set the settings according to that particular export.   

  • Like 1

Share this post


Link to post
Share on other sites
On 10/11/2017 at 11:46 AM, chrisdunham95 said:

Thanks for the tips Neil! 

I also have the soft method working

- still having odd rotation issues with RBD

- Sprites work perfectly except they are invisible?? regardless of what I do to the shade but you can see their moving correctly when highlighted so I'm sure that maybe a small fix

- Fluids I'm still getting the same results regardless of changing resolutions (texture/sim/etc) see the video below - any solutions for any of this would be super handy, :) 

Thanks Guys,

 

2017-10-11-1044-27.flv

I get the same results every now and again.. then I restart. Sometimes this fixes it, sometimes not so much.

Right now I only get black color maps. Something broke between houdini 16.705, and h16.736 it seems.

These effects are awesome when they work.

I've got them in my game at the moment

The button is a soft vertex anim, and the explosions are fluid.

remember to keep color as point data if you want to export colormaps

Good luck man!

Edited by Gerbrand
  • Like 2

Share this post


Link to post
Share on other sites
42 minutes ago, Gerbrand said:

I get the same results every now and again.. then I restart. Sometimes this fixes it, sometimes not so much.

Right now I only get black color maps. Something broke between houdini 16.705, and h16.736 it seems.

These effects are awesome when they work.

I've got them in my game at the moment

The button is a soft vertex anim, and the explosions are fluid.

remember to keep color as point data if you want to export colormaps

Good luck man!

Very nice man :), don't suppose anyone has got sub-uvs/flipbooks in unreal to work with custom color passes from Houdini - Use the color pass to pick which sub uv texture to use for example? - UE4 more than Houdini related question but any idfeas would be great, had some success with messing around but not to the extent I want,

Thanks guys

Chris - PS ; (Vertex Animation tools Beta - all work fine for me now for all export types :) )

Share this post


Link to post
Share on other sites

anyone know why this happens on fluids?

I have polyreduce set to number, and i force it to 10000 polys, so i don't think its a polycount thing.

I even tried a version where I used 1010 as the target on the export. No dice.

broken.PNG.488cbafd1751761a642bf79af19a11b3.PNG

houdini.PNG.3bb1d3d1918840516fc470e5efae0ad3.PNG

Share this post


Link to post
Share on other sites
19 minutes ago, Gerbrand said:

anyone know why this happens on fluids?

I have polyreduce set to number, and i force it to 10000 polys, so i don't think its a polycount thing.

I even tried a version where I used 1010 as the target on the export. No dice.

broken.PNG.488cbafd1751761a642bf79af19a11b3.PNG

houdini.PNG.3bb1d3d1918840516fc470e5efae0ad3.PNG

Few things to check - inside your UE4 shader/material make sure your frame range is set correctly (1-100 in Houdini is 99 frames for unreal)

- Inside your mesh fbx in UE4 check full precision UV's (can sometimes make a difference)

- and can also check your normal before the export over?

- Another lil thing is going into your UE4 position maps/textures and changing the filter to nearest (more precision)

Let me know if any of these fixes your issue :)

Share this post


Link to post
Share on other sites

there must be something weird with my setup.. I took a break, came back, saw your post, and opened the project.

Guess what.. It's fixed

I only stepped away, and came back, so either it was fixed by a magical unicorn, or my 2 year old is better at this shit than me.

Weird

G

  • Like 1

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×