Welcome to od|forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Etherloth

[Solved] Unable to read files (importing geometry issue)

30 posts in this topic

Ok so, I have tried to put:

"C:\Program Files\Side Effects Software\Houdini 16.0.504.20\bin;&" 

in the PATH variable, but did not solve the issue (even restarted the computer just in case). :(

 

If I enter in cmd echo PATH  it returns

PATH

 

if I enter echo $PATH  returns

$PATH

 

What should actually return the echo?

Share this post


Link to post
Share on other sites

One more note, before I think I copied wrong the PATH inside About Houdini cos it was clipped by the window, the actual whole thing is (after the change in the environment variable): 

C:/PROGRA~1/SIDEEF~1/HOUDIN~1.20/python27;C:/PROGRA~1/SIDEEF~1/HOUDIN~1.20/bin;C:/PROGRA~1/SIDEEF~1/HOUDIN~1.20/toolkit/bin;"C:\Program Files\Side Effects Software\Houdini 16.0.504.20\bin;&"

 

Share this post


Link to post
Share on other sites

Looks like window uses the following to print the PATH. Please try:

echo %path%

 

echo $PATH will return the set PATH variable i.e. 

Quote

 

PATH (variable) PATH is an environment variable on Unix-like operating systems, DOS, OS/2, and Microsoft Windows, specifying a set of directories where executable programs are located. In general, each executing process or user session has its own PATH setting.

PATH (variable) - Wikipedia

 

 

1 minute ago, Etherloth said:

One more note, before I think I copied wrong the PATH inside About Houdini cos it was clipped by the window, the actual whole thing is (after the change in the environment variable): 


C:/PROGRA~1/SIDEEF~1/HOUDIN~1.20/python27;C:/PROGRA~1/SIDEEF~1/HOUDIN~1.20/bin;C:/PROGRA~1/SIDEEF~1/HOUDIN~1.20/toolkit/bin;"C:\Program Files\Side Effects Software\Houdini 16.0.504.20\bin;&"

 

Yeah - that first bit is stuffing you up. It needs to be a clean path.

Can you paste here the line in the ENV file please where you are setting the PATH

 

 

Share this post


Link to post
Share on other sites

The value of the PATH environment variable I have set up in windows is a copy/paste of what you have suggested before, so:

"C:\Program Files\Side Effects Software\Houdini 16.0.504.20\bin;&"

And if I enter echo %PATH%  in cmd it returns now the proper value set on the variable, so the one quoted above ^

Inside Houdini, though, the PATH still shows as

C:/PROGRA~1/SIDEEF~1/HOUDIN~1.20/python27;C:/PROGRA~1/SIDEEF~1/HOUDIN~1.20/bin;C:/PROGRA~1/SIDEEF~1/HOUDIN~1.20/toolkit/bin;"C:\Program Files\Side Effects Software\Houdini 16.0.504.20\bin;&"

Mh, any idea of why would it be adding all that stuff before the actual PATH that we have set? :/

Share this post


Link to post
Share on other sites

yep, those are the paths to Python and the Houdini toolkit. At this stage I don't have a Windows box to test with but at a guess can you try to the Env variable for Windows:

 

Windows XP
  1. Select Start, select Control Panel. double click System, and select the Advanced tab.
  2. Click Environment Variables. ...
  3. In the Edit System Variable (or New System Variable) window, specify the value of the PATH environment variable. ...

Share this post


Link to post
Share on other sites

Mh, but the existing PATH in Houdini already has a part that says:

C:/PROGRA~1/SIDEEF~1/HOUDIN~1.20/bin

Which is a clipped version of:

C:\Program Files\Side Effects Software\Houdini 16.0.504.20\bin

Shouldn't this be enough to point the program towards the correct stuff? Or does it have to have it twice no matter what like in an array?

I tried to delete PATH totally from windows environment variables and tried again (unsuccessfully) and Houdini was returning me a %PATH% in the end of the PATH content from the info within the application.

 

For the record, I also tried to delete my preferences folder and put on the PATH environment variable value the following:

C:/PROGRA~1/SIDEEF~1/HOUDIN~1.20/bin

C:\Program Files\Side Effects Software\Houdini 16.0.504.20\bin;

"C:\Program Files\Side Effects Software\Houdini 16.0.504.20\bin"

"C:\Program Files\Side Effects Software\Houdini 16.0.504.20\bin;"

"C:\Program Files\Side Effects Software\Houdini 16.0.504.20\bin;&"

but does not work at all as well :( 

 

Running out of ideas here.

Share this post


Link to post
Share on other sites

3 things to try. You should also try the latest daily build, contact support and install Linux, until you can get the Windows version working.

Would be good to hear from another Windows users what their PATH looks like.

Share this post


Link to post
Share on other sites

Does your system user name have illegal characters present? Or is it really userName as you have listed in post#1?

Share this post


Link to post
Share on other sites
8 hours ago, marty said:

3 things to try. You should also try the latest daily build, contact support and install Linux, until you can get the Windows version working.

Would be good to hear from another Windows users what their PATH looks like.

Thanks @marty for all the answers and help )

8 hours ago, Atom said:

Does your system user name have illegal characters present? Or is it really userName as you have listed in post#1?

Nope, MASTER is simply what I am using which AFAIL should be 100% fine, thanks for your answers as well @Atom - Still wondering what was that PATH related line in .env that you mentioned a few times, I have nothing about PATH in there and perhaps is worth a shot )

Edited by Etherloth

Share this post


Link to post
Share on other sites

I noticed that some kind of files were actually importing/exporting properly and after checking on my Comodo Firewall program I got to realize that the ones that didn't had their respective executables blocked access to local host... not sure why Comodo did this, perhaps every time I tried to export/import there was a dialog popping in the background (as is usual in Comodo, it asks EVERYTIME a program wants to do anything meaningful in your system) and unlike in the normal cases when Comodo query has visual priority over the program that attempts to do something, with Houdini looks like these popups are left in the background, at least in my machine, therefore by default all these converters got blocked.

 

TLDR: Make sure your file converters have clear access to your localhost.

 

Now all OBJ and other formats are read/wrote perfectly.

 

Thanks all the thread contributors for the help on this matter, hope this can help others in similar situation.

 

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now