Welcome to od|forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
ejr32123

resume caching

Hi,

Another question about caching : ).  I go to my dop network, then output, then save to disk my pyro simulation cache. My pc crashes at frame 55. So I start houdini and load frame 54. I start caching again from frame 54, but the simulation has to start from frame 1 - 54 before it can cache frame 55 and the rest. Why is this? 

Thanks

Share this post


Link to post
Share on other sites

Because a simulation evolves based on the values from the previous frame, unlike a sop network which is calculated per frame with no time dependency. In order to get to frame 54 you need to calculate frame 53 and in order to get to frame 53 you need to calculate frame 52... etc etc all the way back to the start frame. These values are not stored when you save a bgeo file, you only save the result. You can save a .sim file which would allow you to start again from frame 54, but they take up a huge amount of space as they have to save all that additional information about the simulation's state. 

Share this post


Link to post
Share on other sites
33 minutes ago, woodenduck said:

Because a simulation evolves based on the values from the previous frame, unlike a sop network which is calculated per frame with no time dependency. In order to get to frame 54 you need to calculate frame 53 and in order to get to frame 53 you need to calculate frame 52... etc etc all the way back to the start frame. These values are not stored when you save a bgeo file, you only save the result. You can save a .sim file which would allow you to start again from frame 54, but they take up a huge amount of space as they have to save all that additional information about the simulation's state. 

The output from the dop netowrk is saving out.sim files. See what I am saying? I am saving the raw sim files, but it is still making me start over.

Share this post


Link to post
Share on other sites

Try changing your start frame to 54 and putting the path to the frame 54 sim file in the "initial state" parameter.

1 person likes this

Share this post


Link to post
Share on other sites

See at the bottom, it still cooks from the beginning. It should start at 110. I tried setting the initial state with the sim file.

work.PNG

Edited by ejr32123

Share this post


Link to post
Share on other sites

Did you change "start frame" on your dopnet? 

1 person likes this

Share this post


Link to post
Share on other sites
19 minutes ago, woodenduck said:

Did you change "start frame" on your dopnet? 

Hah! That is the problem. Thanks : ). The only weird thing is that now, when it saves the file, it names frame 111 frame two because it thinks 110 is frame one. I just changed $SF variable to `$SF+109` and now it correctly saves as frame 111. Again, thanks so much for the solution.

Share this post


Link to post
Share on other sites

No problem! You could also use $F which is the global frame number. $SF is the simulation frame number. 

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0