Jump to content

Recommended Posts

Hi everyone,

I'm currently working on a blast/pyro effect, and I need some advices about fast colliders.

I've fast moving collider that doesn't affect correctly my pyro. the solver seems to be unable to correctly evaluate the motion of my object.

Any idea about how to solve this problem. I've a simple animated VDB collider (2 fileds vel and collisionvel) 

 

Cheers

Bertrand

Share this post


Link to post
Share on other sites

Normally increasing the substeps should do the trick.
Also, make sure on your Sop to Dop bindings, you are using the correct vdb names.

Share this post


Link to post
Share on other sites

On the Pyro Solver under Advanced TAB, then Collision, you may want to try turning off Correct Collisions. Sometimes this correction is wrong for fast moving objects.

Edited by Atom

Share this post


Link to post
Share on other sites

Many thanks for the answers!

Increasing the solver's substeps changes the pyro behavior, and turning off correct collision didn't change anything :/

Thanks 

Bertrand

Share this post


Link to post
Share on other sites

If you are saving your volume collisions to disk then you only have integer frames using $F but using $SF will give you the substeps. Sub samples in your second sim probably won't do much otherwise.

 

So export your collision volumes with whatever substeps are required and make to two sims match using volume.$SF.vdb

 

that's my guess anyway.

 

Share this post


Link to post
Share on other sites

If you want better collision behavior, you have two options. By default the smoke/pyro solver uses the Multigrid projection method with just one iteration; This method is very fast but not good to deal with collisions, so try to increase the iterations, that can help a little bit. The second option is to change the projection method to PCG, its slower than multigrid, but gives a much better collision behavior!

You can find this option on the Advance/Projection tabs in the solver.

I hope this helps you!

Alejandro

Edited by Pazuzu

Share this post


Link to post
Share on other sites

Thanks Alejandro, increasing the iteration and unchecking the Correct Collisions seemed to give me something more promising. Although I would like to see how your suggestion results in. I'll give that a go today. Thanks many.

rodmac, I was under the impression that when substeping, timeblend-ing does the same thing. You just need to do it before converting to a volume? I might be mistaken though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×