Jump to content
Sign in to follow this  
scorpes

H16 Ocean with Mantra problem

Recommended Posts

scorpes    1

Hi, I'm trying to render a H16 Ocean test with Mantra. This is pretty standard guide ocean preset, got problems that I randomly get black fluidcontainer frames in the render sequence (local render). it's on different frames every time I rerender this. Any idea what it can be? Check gif below..

Gr Robbert

 

ezgif-2-a913737441.gif

Edited by scorpes

Share this post


Link to post
Share on other sites
Matt_K    25

Hey Robbert,

It's probably because a few frames haven't meshed properly. Have you cached the 'particlefluidsurface' output to disk?
If so, you can then step through and find any broken frames and try tweak the settings to get it to mesh correctly, and re-cache just those frames.

Otherwise, perhaps the spectra mask files aren't being correctly generated - check the filesizes if you cache them out and see if there are any 0kb ones.

Lastly, on the geometry node that your ocean is in, try setting the dicing mode to 'full predicing' - ( yourGeo > Parameters > Render > Dicing ).
This will use a more memory at render time but has fixed issues for me with rendering oceans, and can actually speed up rendering.

Hope that helps!
Matt.
 

Share this post


Link to post
Share on other sites
scorpes    1

Thank you for the reply Matt,

This test is with full predicing enabled. I did cache the fluid Flip particles with a fluidcompress node, but I did not cache the particlefluidsurface itself. I'm going to make a test with a cached particlefluidsurface and I get back with the results. The spectra masks should be fine.

Any ideas how I can speed up the Mantra rendering? It renders an hour per frame at 720p (pretty noisy settings). If I turn on Motionblur it takes hours per frame.

Settings: Mantra PBR, pixel sampling 7x7, min 1, max 7, noise 0,09, reflect limit 2, refract limit 1, diffuse limit 2, color limit 3. (rest is default)

 

 

Share this post


Link to post
Share on other sites
Matt_K    25

Hey again,

Your settings seem ok, though I tend to keep my diffuse limit to 1, really helps to reduce noise. Often the second diffuse bounce doesn't really add a lot more to the image.
Check your displacement bound - try and get it as low as possible before artefacts appear, as that may speed things up as well.
And try and keep your lighting rig simple - I usually have a sun light and an hdri, and that seems to work well in most cases.

As a last resort, try rendering without the fluid interior - can really speed things up, but it will look quite different.

Without knowing what else is happening in your scene, I'm afraid that's about all I can suggest!

Matt.
 

Share this post


Link to post
Share on other sites
scorpes    1

Yes it's now working, it was the particlefluidsurface , which can be a bit unpredictable frame to frame. I increased the Pad Bounds and now it works correctly :) Thanks for helping m8

On 6/14/2017 at 7:16 PM, scorpes said:

This test is with full predicing enabled. I did cache the fluid Flip particles with a fluidcompress node, but I did not cache the particlefluidsurface itself. I'm going to make a test with a cached particlefluidsurface and I get back with the results. The spectra masks should be fine.

Any ideas how I can speed up the Mantra rendering? It renders an hour per frame at 720p (pretty noisy settings). If I turn on Motionblur it takes hours per frame.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×