Welcome to od|forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Dave Stewart

FLIP Viscosity - Collision object grid stepping artifacts

Hi All! I'm wondering if anyone has run into this and found a good solution, it's been popping up in my low-to-mid viscosity sims for a while. Perhaps I'm missing something stupidly obvious? Collision geo/field are fine and the interface between fluid and collision object looks great before turning on viscosity, then I get these grid artifacts that are tough to get rid of. Reducing Surface Extrapolation way down in Volume Collisions helps but doesn't completely remove the artifacts. Also, using a high slip-on-collision value helps, but I usually don't want the sliding behavior with sticky viscous fluids. Reducing Grid Scale reduces the relative grid size and helps too, but the artifacts are still there, just smaller.

Attached file is somewhat of a worst-cast example, just curious if other folks have dealt with this before. I know I can run some post-sim tweaks to clean up the collision surface intersection, but I've also noticed that the artifacts reveal themselves on the outer surface of the fluid if it gets thin enough, which is not so easy to fix...

01 - viscosity disabled

02 - viscosity enabled

03 - viscosity enabled, surface extrapolation 0.01

Thanks in advance for any help/ideas!!

--Dave

FLIP_ViscosityStepping_01.JPG

FLIP_ViscosityStepping_02.JPG

FLIP_ViscosityStepping_03.JPG

DStewart_FLIP_ViscousCollisionStepping.hip

Share this post


Link to post
Share on other sites

have you tried increasing the sub steps on the solver when you turn viscosity on?

Machine tied up but I'll have a look at your hip when i can - that's an interesting artifact.

cheers

Nigel.

Share this post


Link to post
Share on other sites

I can confirm your original findings. It does look like viscosity creates a stepping pattern. My guess is that behind the scenes the viscosity is fetching a lower resolution of the collision object.

 

This would be a nice example file to submit to SESI as a bug.

Share this post


Link to post
Share on other sites

shrink the collision shape a small amount perhaps to help it sit on the surface a little more?

Share this post


Link to post
Share on other sites

Thanks for taking a look at this guys! It seems that it may be a limitation of the viscosity solver, as it's decoupled from the pressure solve. Sounds like this may get addressed in a future version though!

https://cs.uwaterloo.ca/~elariono/stokes/index.html

I'll go ahead and submit the file to SFX to see what they say about it.

Nigel, increasing substeps doesn't seem to have any affect on the artifacts.

Atom, it could be that or just a velocity matching issue relative to the grid scale. Got some interesting thoughts on this in the Houdini Artists FB group.

Anthony, I did try that and it helps with the fluid surface/collision interface, but not when the artifacts appear on the outside surface of the fluid as it gets very thin.

Cheers,

--Dave

 

Share this post


Link to post
Share on other sites

Hi Dave

Thanks for that link. There's a link to a github for download of a new stokes microsolver which sounds like it could address your issue.

cheers

Nigel.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now