Jump to content
captainbuckfish

FEM DOPEmbedded geo issue

Recommended Posts

Morning,

Woking on some FEM stuff but having some issues. First image you can see the nodes used to create the scene.597a93bbc2d5a_FEM1.thumb.jpg.b7bcfc86e0107d6adc111cb8e2cd2b85.jpg

The transform has CHOPS applied to the rx value with some noise for animation. Point deform captures this animation. The isooffset is used to group internal points on the tets and used for constraints in the sim.

597a940cdf464_FEM2.thumb.jpg.3884f5bb95ac9d93a4bceb62bdf5f514.jpg

In DOPS its set as an organic mesh and the target is set to follow the animation.

Everything works great (love FEM) but.... having some bad results on the embedded geo as you can see in the first image (FEM 1 ) Why do the results come out like this? It also doesnt follow the sim very well.

If i use just a standard point deform the reults are better and it follows the animation tighter.

597a940e9aa70_FEM03.thumb.jpg.01371e364bc005eb83667be1c5e6ee4e.jpg

So why do we use the Embedded Geo option? How can the result be improved.

Weird job where the client wants unicorns abused this way... but will upload a .hip with simpler geo when I have chance.

Cheers

 

Duncan

Edited by captainbuckfish

Share this post


Link to post
Share on other sites

looking at the resolution of the tet mesh in the middle image i would say its perhaps a little high so the embedded geo is struggling a bit to pick which point to work with.  Maybe try lowering the resolution of the tet mesh (solid embed) perhaps and see if that smooths out the deformation on the embedded?

Share this post


Link to post
Share on other sites

I went with the point deform setup for this job. These unicorns fell from the sky and did weird jiggle dances at the clients request.

I have attached the .hip with the model so people can check it out and advise better ways to work with this. First time to get FEM working on a project and was happy with the results need to do more tests and understand its workflow.

 

FEMM HORSE.rar

Share this post


Link to post
Share on other sites
trzanko    40

Make sure the tet cage completely encompasses the embedded mesh. 

Check out the example file at the bottom of the solid embed node for how to get a nice embedded mesh going. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×