Jump to content
Sign in to follow this  
ejr32123

Help With Ocean Surface

Recommended Posts

Hey, 

It would be amazing if someone could help me with this problem. When I render my beach sim the surface looks terrible with these spots. It seems that the surface renders differently depending if the particle fluid surface is below my ground mesh or above. Look at the photos. Photo 1 you can see white spots where the mesh is not penetrating ground. Render two I moved the ground mesh so it is not penetrating at all. Render 3 is the back side of the of render 1. See the white spots on photo 1 correlate with the parts where the mesh does not penetrate the ground. What do I do? How do I fix this?

Thanks

1.PNG

2.PNG

3.PNG

test.hipnc

Share this post


Link to post
Share on other sites

This is a problem that seems to occur with physically accurate shaders.  Once there is a gap between the two objects it assumes it full of air and you end up with that milky look.  The quickest way I have found to get around it is by extending your mesh down into the ground.  You can do this by moving the points of your mesh down that have a negative Y Normal.  Or you can just raise up your beach geometry slightly.

Share this post


Link to post
Share on other sites

There is also an option to substact the collision volume in the mesher.

And if that doesn't give you nice results you still could convert the bottom to a vdb and substact that from the fluid vdb before meshing it.

Cheers

Rico

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×