Welcome to od|forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

richard_mcd_green

POP collision not working properly

Hi,

I'm trying to collide some particles with a simple collision object and a ground plane, however whenever I enable the collision objects in my scene the particles seem to be colliding in midair instead of with the objects. The collision preview looks fine and I've tried adjusting the collision tolerance of the particles but to no avail. the sim works when I bypass the collision objects. Any idea why this could be happening?

sim.zip

Share this post


Link to post
Share on other sites

Ok, here is my rework of your scene, not sure if it is right.

Here is what I changed.

Inside the popnet you want to keep an eye on how the merges work. Some merges work based upon left input affecting right input and others work based upon a mutual relationship. In shelf tool configurations, static is always on the left of what it is colliding with. Then RBD is mutual. I re-wired the nodes to reflect this.  I also added gravity to the scene.

Once you have a popnet output with colliders, you have to make sure you don't import the collision geometry as the popnet result. So alter your ObjectMerge on the popnet to remove the ground plane and the bench like so. This will give you only the particles as the result.

* ^rbdobject1 ^groundplane1

 

 

catch_petals.gif

ap_Hand2.hiplc

Edited by Atom

Share this post


Link to post
Share on other sites

Hey Atom,

Thanks for taking a look, I didn't know that about merge nodes or the object merge, so that's really useful! However, the problem was persisting once I added back in my other pops and popwrangle. I eventually worked out that the problem was coming from the wrangle, it was setting the max pscale to 1.3, which was way to big for the scene hence the instant collisions! I hadn't noticed because my geo was copying onto the particles at a decent size, but that is because it was small to begin with. However this is now fixed!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now