Jump to content
ikatz001

FLIP sim refraction rendering artifacts

Recommended Posts

 

Hi all,

I'm getting strange artifacts rendering a flip simulation with the PBR shader set to glass preset.
 
As you can see there are lots of flickering and some features of the mesh even go in and out. 
 
If refractions are turned off the problem disappears, however the desired look is no longer achieved. The problem is not present on other presets such as gold, etc.
 
Im guessing this has something to do with how the particlefluidsurface node meshed the sim, being inconsistent with the inner features or something like that.
 
Is this a known issue or something anyone have come across? Can you think of anything to help me resolve it?
 
Thanks in advance,

Glass_Test_s.zip

Share this post


Link to post
Share on other sites

I have figured out its indeed in the meshing. Somehow the union fluid compress is making major changes on random frames. Its as if when it passes a certain threshold it extrapolates in a different direction and whole internal features of the mesh change from frame to frame in a major way. I've been trying to mess around with it but so far have not been able to solve how to make it give consistent results. Also my compressed particles from where its meshing only have 4 levels of cull bandwidth, which seemed enough at the time. Now im thinking maybe its not, or maybe it has nothing to do with it.

Anyone have lots of experience meshing FLIPs that would like to chime in with insight into this problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×