Jump to content
JJ FX

Background image

Recommended Posts

Hi, 

Im trying to set the background image for my camera. I can set background for any perspective, ortographic views, but not for camera. The path to image sequence is grayed out. How can I unlock that?

Share this post


Link to post
Share on other sites

i think it's greyed out when you already have an image in perspective view in viewport display options. not absolutely sure, it shouldn't normally be greyed out thou

Share this post


Link to post
Share on other sites

It's greyed out because the camera is currently defining the background image. If you lock the view to the camera then it'll enable these options, and any changes you make will be applied to the camera Background Image parameter.

Share this post


Link to post
Share on other sites

Great!

Now... how can I make it animated :D? Because using file loads up a single frame. When using COPs, some frames I get a weird cropping like that:

img.png

Share this post


Link to post
Share on other sites

filename.`$F`.jpg

$F takes whatever is your frame number on timeline. $F4 will take that frame number with padding (i.e. 0001 instead of just 1)

if you have different numbering you can use something like 

filename.`$F - 1000`.jpg

Share this post


Link to post
Share on other sites
5 minutes ago, davpe said:

filename.`$F`.jpg

$F takes whatever is your frame number on timeline. $F4 will take that frame number with padding (i.e. 0001 instead of just 1)

if you have different numbering you can use something like 

filename.`$F - 1000`.jpg

Seems not to be working for Disk File option. $F evaluates to the current frame on the time slider. In my case background.$F6.tga  > background.098766.tga - and stays like that

Edited by JJ FX

Share this post


Link to post
Share on other sites

that's probably bcs numbering of your files is wildly different from your timeline frame numbers. you have to compensate for that so those two match. so if you want that file background.098766.tga to be visible on frame 100 you need to type "background.`$F6 - 98666`.tga

Share this post


Link to post
Share on other sites

No the frame range and time range mathes fine. Just right after I type in ".../bg.$F6.tga" or ".../bg.`$F6`.tga" it converts to the current selected frame, lets say ".../bg.079552.tga". And does not update when sliding the timeline, because it converted to a strict value ".../bg.079552.tga"

Share this post


Link to post
Share on other sites

dunno, works for me... i usually select a sequence from file browser and it just works if frame numbers are matching. tried it just now. expression is simply 

path_to_files.$F.jpg

Edited by davpe

Share this post


Link to post
Share on other sites

Why you dont you use the background image on the camera? If you have you sequence loaded into COPs is gonna read the sequence just fine.
then in your BG of the camera you bring the COP network

op:`opinputpath("../cop2net1/OUT_SH080",0)`

 Also make sure to make your timeline the match the sequence number, so if you start tracking at 1001, just set up your timeline correctly before bring the track info. (You do not have to, but it just easier)

Cassspture.PNG

Share this post


Link to post
Share on other sites

It's a bug, the $F is lost so you need to set a key frame on the path to make it work.

 

Please submit it As a bug to SESI as it's been there forever and needs to die.

 

thx!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×