Jump to content
BrookerT

Flip Fluid Collision Problems

Recommended Posts

Hello! 

I am having a problem with collision for my flip fluid sim, frame 2 for some reason a chunk of particles falls through the bottom of my "cup" I've checked my collisions on my "cup" and I've also tried adding a sub d node in my tree. both didn't have any result. Also, as the sim continues my particles pretty much all disappear. I'm pretty new to water sims so I'm not really sure the problem.

 

Thanks! 

watersim1.PNG

watersim2.PNG

Share this post


Link to post
Share on other sites

Looks like you need some thickness, use a polyextrude to create a thick barrier around the cup. Then in the dopnet, check the Collision guide under the Flip Fluid Object node to see it's true representation

Share this post


Link to post
Share on other sites

In a previous version I had thickness but it would still fall through the bottom, mind you it would just catch in the bottom layer but still fall through nonetheless. My secondary problem with the particles disappearing would still happen as well when I played my animation.

Share this post


Link to post
Share on other sites

Basically what Sean said. Give the cup some thickness. In your cup Static Object, make sure you have an adequate collision representation. Uncheck Display Geometry and turn on the Collision Guide, and adjust the Division Size under Collisions > RBD Solver > Volume.

Once that looks good you'll want to make sure that the FLIP Object is creating adequate collision geometry from that. Turn on the Collision guide. To increase the resolution of the collision geometry created by the FLIP Object you can decrease Particle Separation, or enable Collision Separation and give it a value not tied to Particle Separation. Beyond that if you notice wonky behavior, like a few particles penetrating anyways, try increasing your substeps on the FLIP Solver. If trouble persists, please upload a file.

Share this post


Link to post
Share on other sites

So the advice worked! The water is staying where it's supposed to in the beginning,  but then it will not leave the cup, its acting like there's and invisible polygon on the top stopping the particles from coming out. I've attached my scene file, the particles are supposed to go out and kinda "spray".  

splashFX_lookdev_v012.hipnc

Share this post


Link to post
Share on other sites

Change Collision Detection on your cup static object to "Use Volume Collisions". The Surface Collisions are in fact generating some polygons at the top of the cup.

Edited by DaJuice

Share this post


Link to post
Share on other sites

After changing to volume collisions it works, one last question though. Why do I need double polygons? Is there a way to have single polygons but increase collision thickness? Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×