Jump to content
Sign in to follow this  
SquirkyTurtle

Glowing Material not affecting other objects

Recommended Posts

Hi everyone!

I am trying to emit light from a material but while the material is glowing, the other objects in the scene are not affected by the light. I have used the glow material to drive the colour emission on my princiled shader. Does anyone know what I am doing wrong, or should I approach this differently? I would be grateful about any help :)

Share this post


Link to post
Share on other sites

I think on your Mantra ROP, set indirect diffuse bounces to a number greater than 0.

 

Another method is to use an Indirect Light set to "Irradiance Only"

Edited by jkunz07

Share this post


Link to post
Share on other sites
17 hours ago, jkunz07 said:

I think on your Mantra ROP, set indirect diffuse bounces to a number greater than 0.

 

Another method is to use an Indirect Light set to "Irradiance Only"

Thank you so much for your reply! I can't seem find the indirect diffuse bounces setting you were referring to but I tried it using an indirect light. I am getting a lot of noise though and incredible high render times. I am wondering if I am doing something wrong. 

I considered using a geometry light instead but I want the light to only emit in certain areas. Is there any way I can use the layered material as some kind of a mask for the geometry light or should I approach this differently? Sorry about all the questions :)

Share this post


Link to post
Share on other sites

By diffuse bounces, I was referring to the "Diffuse Limit" parameter.  This is found on the Mantra ROP under Rendering -> Limits -> Diffuse Limit

 

If you use a Geometry Light, you'll have the advantage of being able to use photon caching (GI) techniques to speed up the renders.

I'm not sure how you have your scene or material layers set up, but it should be pretty simple to do.

Share this post


Link to post
Share on other sites
On 16/11/2017 at 2:33 AM, jkunz07 said:

By diffuse bounces, I was referring to the "Diffuse Limit" parameter.  This is found on the Mantra ROP under Rendering -> Limits -> Diffuse Limit

 

If you use a Geometry Light, you'll have the advantage of being able to use photon caching (GI) techniques to speed up the renders.

I'm not sure how you have your scene or material layers set up, but it should be pretty simple to do.

Thank you so much! I got it and it works fine now :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×