Jump to content
Sign in to follow this  
Atom

[SOLVED]Enable Write On NTFS Drive Under Ubuntu 17.10?

Recommended Posts

I have Houdini up and running on Ubuntu. All my previous work was created on a 1TB drive that was formatted on a Windows 10 system. While I can see files on the drive and Houdini can load my HIP files, I can't actually save anything on the drive.

Does anyone know how to enable write access to a NTFS drive on Ubuntu?

Edited by Atom

Share this post


Link to post
Share on other sites

Not sure but stackexchange or google is the goto place for Linux questions.  You'll encounter quite a few!

Iirc fat* is the only interchange format available 

Edited by marty

Share this post


Link to post
Share on other sites

NTFS isn't a Linux native file system. I strongly encourage you to use a Linux native file system. Seriously. Recent versions of Ubuntu come with ntfs-3g by default which will let you read and write NTFS so it's likely a permission issue, not anything related to the fact that it's NTFS. If the permissions are sane then it's likely the NTFS volume is damaged (ntfs-3g will mount as read only if serious errors are found). More reasons why you shouldn't use NTFS on Linux...

  • ntfs-3g is implemented with FUSE which is user space framework instead of kernel space so it's stupid slow compared to native file systems
  • Linux has no comprehensive NTFS check utility so errors go unnoticed and can compound
  • Some applications use extended attributes which can't be stored in foreign file systems like NTFS

Share this post


Link to post
Share on other sites

I am currently copying all the files to an external drive and then I will try to format that NTFS drive natively. That is the ext4 format right? Then I'll copy things back.

I notice the Files app does not have a format option. Is that something gparted can do?

Edited by Atom

Share this post


Link to post
Share on other sites

I have managed to transfer all my files off of this problem drive. I have now created a new partition ext/ext4 but I still can't write anything to this drive.

Do I have to format the drive?

What program do I use to format the drive? gparted does not seem to have a format option.

gparted.jpg

Share this post


Link to post
Share on other sites

I finally found a solution.

sudo chown -R $USER:$USER /media/banedesh/Storage

Where media/banedesh/Storage is the mount point on your system.

Share this post


Link to post
Share on other sites

Looks like you got it all working. That's good. Note that Linux assumes nothing about permissions. Windows assumes a lot. That chown command changes the owner of the directory (which is the entire drive in this case).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×