Jump to content
yogeshdhuri

Particle Colliding with bound of the VDB instead of VDB shape

Recommended Posts

Hi Everyone,

I am still new to houdini and I frequently run into the following problem.

WhenI use VDB volume for collisions in houdini Particle or Flip sim, particles collide with the bound of VDB volume instead of actual VDB shape. It kind of creates a boundary around VDB and uses that boundary for collision. Its visible in the viewport in orange color (yellow color in the provided SS as d object was selected when took SS). I often get this issue and I dont know what I am doing wrong and how to solve it. Even If I use shelf tool the problem still persists. If anyone of you have ran into this problem then please let me know how u solved it. thank you for your time.

 

Cheers!!!

houdini collision issue 2.jpg

houdini collision issue.jpg

Share this post


Link to post
Share on other sites

Enable your collision guide by that BLUE color chit. That is what the particles are going to collide with, not the display mesh geometry. 60 divisions may not be enough, try 96 or 128.

Share this post


Link to post
Share on other sites

Thanks for the reply.

I found the cause of the problem. The sim was lowres thats why collision was inaccurate. As soon as I reduced particle seperation the collision started to work fine.

Now overall sim is ok but when I try to reduce particle seperation more, few particles start shooting out. Any solution for that? And also I want some of the particles to stick to the character. How to achieve that.

Thanks again.

Share this post


Link to post
Share on other sites

On the popsolver1 enable Add Hit Attributes and then select Stick from the Response drop down that defaults to "Unchanged". For the stray particles come up with a way to detect them either by placing a bounding object around your simulation followed by a Delete (non-selected) or using vex to examine the velocity. If the shooting particles have a high velocity you can use VEX removepoint() to take those out of the mix.

Edited by Atom

Share this post


Link to post
Share on other sites
2 hours ago, Atom said:

On the popsolver1 enable Add Hit Attributes and then select Stick from the Response drop down that defaults to "Unchanged". For the stray particles come up with a way to detect them either by placing a bounding object around your simulation followed by a Delete (non-selected) or using vex to examine the velocity. If the shooting particles have a high velocity you can use VEX removepoint() to take those out of the mix.

Thanks Atom for the reply. I used POP Speed Limit to counter abnormal velocities in the particles. For now it looks like working fine. I am doing a few iterations with it.

About particles sticking to the character will try your suggestion.

Cheers!

Share this post


Link to post
Share on other sites
On 12/17/2017 at 9:49 PM, Atom said:

On the popsolver1 enable Add Hit Attributes and then select Stick from the Response drop down that defaults to "Unchanged". For the stray particles come up with a way to detect them either by placing a bounding object around your simulation followed by a Delete (non-selected) or using vex to examine the velocity. If the shooting particles have a high velocity you can use VEX removepoint() to take those out of the mix.

Hi Atom. I tried your suggestion and I am able to get particles stick to the surface now. But is ther any way to controll the number of particles sticking on the surface or occasionally let some particles fall off. currently there are too many of them sticking onto the character and most of them stay stuck till the last frame.

Thank you.

Cheer!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×