Jump to content

Recommended Posts

Using Houdini FX 16.5.268, created a project with a lot of particles and ran some previews in the timeline, export as alembic to C4D which worked great. However upon re-opening the same project, a "DOP Cook" has to go through all 135 frames and takes a long time to complete. 

I'm very recent (noob) to Houdini, and am wondering if there is a way to open without the DOP Cook thing running? I can hit Esc to cancel, but my nodes all appear with red triangles behind them and I'm not sure if this is good or bad (breaks simulation or something not advisable?). Any pointers would be very much appreciated, thanks for your time helping the lesser of us Houdini users :P

Share this post


Link to post
Share on other sites

you can open Houdini in manual mode 

houdini -n file.hip

That you will be one way to do it. Also you could just open the file and save the scene again at frame 1.

Share this post


Link to post
Share on other sites
26 minutes ago, Sepu said:

you can open Houdini in manual mode 

houdini -n file.hip

That you will be one way to do it. Also you could just open the file and save the scene again at frame 1.

Is this for MacOS command line? I'm on Win 7, doing this on cmd isn't "recognized" as a command. I'm cd under the C:\Program Files\Side Effects Software\Houdini 16.5.268 directory too in cmd. 

Share this post


Link to post
Share on other sites

it should be

houdini.exe -n myfile.hip

either with the powershell or cmd or something similar 

Share this post


Link to post
Share on other sites

I tried to launch Houdini and set the update mode to Manual, then opened the hip file. It worked. Not sure if it is a recent improvement, since I only saw command line solutions, but it seems you are no longer need to launch Houdini with command line option to avoid long cook.

"houdini" and other Houdini commands will work in Houdini Command Line Tools, which has environment paths set. For the cmd, "houdini.exe" is in the "bin" folder from where you are now, so you need to cd here. You still need to provide path for the scene file, so, it is faster to just drag executable and scene files right into cmd window to make full paths without need to cd anywhere. It is also possible to launch command window from explorer's context menu holding shift key, and it will automatically set the location.

Share this post


Link to post
Share on other sites
29 minutes ago, f1480187 said:

I tried to launch Houdini and set the update mode to Manual, then opened the hip file. It worked. Not sure if it is a recent improvement, since I only saw command line solutions, but it seems you are no longer need to launch Houdini with command line option to avoid long cook.

"houdini" and other Houdini commands will work in Houdini Command Line Tools, which has environment paths set. For the cmd, "houdini.exe" is in the "bin" folder from where you are now, so you need to cd here. You still need to provide path for the scene file, so, it is faster to just drag executable and scene files right into cmd window to make full paths without need to cd anywhere. It is also possible to launch command window from explorer's context menu holding shift key, and it will automatically set the location.

Was able to get it to open with Illusionist's cmd command line, but then it throws all this at me:

image.png.988acf48d1aaee183f3431f299d2e19f.png

The nodes do load and I can see them finally but the live view window is empty with "Update mode is Manual. View may be out of date".  Even after saving that as a separate new .hip file, still get the same error messages. Perhaps I disconnected a node by accident or something somewhere in the fluid sim?

Share this post


Link to post
Share on other sites

Nothing wrong here.

  1. Common warnings for scene created in different Houdini version. I get bunch of that on scene load quite often. Indicates changed nodes that was used somewhere in the network. If everything works fine, ignore the warnings. If the scene is broken, you have a hint where to look and see if it possible to fix.
  2. The "-n" option tells Houdini to open the file in Manual mode. Switch back to default Auto Update using menu at the bottom right corner of the GUI. There is a little refresh button nearby, which you use when work in Manual.

Share this post


Link to post
Share on other sites
45 minutes ago, f1480187 said:

Nothing wrong here.

  1. Common warnings for scene created in different Houdini version. I get bunch of that on scene load quite often. Indicates changed nodes that was used somewhere in the network. If everything works fine, ignore the warnings. If the scene is broken, you have a hint where to look and see if it possible to fix.
  2. The "-n" option tells Houdini to open the file in Manual mode. Switch back to default Auto Update using menu at the bottom right corner of the GUI. There is a little refresh button nearby, which you use when work in Manual.

Ah, brilliant! Sim is running like normal, just had to hit that Auto Update. Thanks for your patience!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×