Jump to content
Jesus Nieto

How to work with millions of points smoothly

Recommended Posts

You know points in Houdini are the base of Houdini of many effects such as Water, Sand, Magic, Crowds, and other object's instancing target. As I understand a point is the lowest level of information that you can have in Houdini's viewport and the lightest, but when you are making  a water or a sand simulation working starts to become really sloppy due to the millions and millions of points you can get with one of this simulations.

My question is , is there a way to work with say 30 or 200 million points in the view port without losing total control of it? or is there a way to load half or a tenth of the points from disk?

Share this post


Link to post
Share on other sites

There is the fluid compress if you are working with FLIP, I assume you could adapt it to work with other points for viewport visualization. You could also just delete every X point with a delete SOP or wrangle, a bit hackneyed though. Maybe someone else has a better solution.

Share this post


Link to post
Share on other sites

What kind of hardware do you have?

I just scattered 200 million points into a sphere and my 1070gtx seems to handle that just fine. Completely rapid viewport response.

 

Press the D-KEY with your mouse over the viewport. Choose the Geometry tab. There is a percentage value you can adjust for instances.

Share this post


Link to post
Share on other sites
On 15/2/2018 at 5:32 AM, Atom said:

What kind of hardware do you have?

I just scattered 200 million points into a sphere and my 1070gtx seems to handle that just fine. Completely rapid viewport response.

 

Press the D-KEY with your mouse over the viewport. Choose the Geometry tab. There is a percentage value you can adjust for instances.

Hi Atom, I don't understand. I am making sand simulations with the grain solver which end up being around 20 million particles and houdini becomes pretty much useless when they are displaying on the view port. is there a chance that the graphics card is disabled or I am doing something wrong?

Here's the specs of my computer:

Windows 7 Professional 64bit 64GB Intel(R) Xeon (R) E5-2690 @2.60GHz

nVidia GeForce GTX 1080 

Share this post


Link to post
Share on other sites

Ok, I see what you mean. Try disabling the grain sprite inside the AutoDopNetwork.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×