Jump to content
joosefssoon

Animated texture sequence turns pink

Recommended Posts

Hi!

So I've plugged in an animated texture sequence ("TextureName_$F.png) into the principled shader and it works fine, looks like it should etc.

But when plugging in a texture node into base colour and writing the same texture path, the texture turns pink in the render view. When omitting the $F and typing out the frame number manually it shows up but as soon as I type $F it turns pink.

Does anyone have a clue? Google didn't give me much help today.

Thanks!

Edited by joosefssoon

Share this post


Link to post
Share on other sites

pink means the specified file/path couldn't be found. check the console (windows) or terminal (linux) for errors. hard to be more specific without inspecting the scene.

Share this post


Link to post
Share on other sites

Thank you for your reply.

Terminal gives me the following error:

Quote

 mantra: Unable to load texture 'path/texture_1.png'

I am on frame 1002 and there is a texture called texture_1002.png. So it would seem the texture VOP can't understand frame numbers(?)

I can make a scene to showcase my issue. Give me a minute.

 

Share this post


Link to post
Share on other sites
19 minutes ago, StepbyStepVFX said:

Wouldn’t it be a padding problem ?

Look how to use padzero, maybe it will help. You need the exact path to your file in the string (1001 and not 1) : $F is not sufficient 

https://www.sidefx.com/forum/topic/26518/

Thanks for your reply, adding padding to the texture path produces the same error but with padding ("unable to load texture path/texture_0001.png"). So I think the issue is that the texture node doesn't know what frame Houdini is on but rather defaults to frame 1.

Share this post


Link to post
Share on other sites

i duuno, if youre on frame 1001 and the texture is called "something_1001.png", then "something_$F4.png" should work. if it can't be reached Houdini doesn't default anything, it just evaluates the expression which, in your case does not give the correct result. (sorry cant have a look at your hip file right now)

just a thought but sometimes you have to force the expression evaluation by backticks:  "something_`$F4`.png" 

Edited by davpe

Share this post


Link to post
Share on other sites

Backticks produced the same results. But my work-around, by courtesy of my colleague, is to promote the texture path of a surface colour node plugged into the principled shader core. It works but it sure isn't pretty, especially since I can't rename surface colour parameters. So the principled shader now has "texture", "texture" and "texture" promoted. Will keep working and see if I can find a prettier way of doing this.

Thanks for your replies!

Edit: clarification: I can rename the promoted attribute but it's a bit tedious when working with many textures.

Edited by joosefssoon

Share this post


Link to post
Share on other sites

oh i see, didn't thought about this :) if you have an expression in the shader parameter it must be promoted to the top level. you can change a name of the parameter either in the shader (if you select the promoted parameter node) or if you go to Edit parameter interface on the top level.

Share this post


Link to post
Share on other sites
6 minutes ago, davpe said:

oh i see, didn't thought about this :) if you have an expression in the shader parameter it must be promoted to the top level. you can change a name of the parameter either in the shader (if you select the promoted parameter node) or if you go to Edit parameter interface on the top level.

Absolutely, but the issue is when connecting things into the shader in the MAT context (Texture node connected into a principled shader), there is no further level "upwards" so I can't access promoted parameters. And as a result I have to dive into the shader which is less than ideal.

Edited by joosefssoon

Share this post


Link to post
Share on other sites
11 hours ago, woodenduck said:

How about collapsing your shader network in to a material and promoting the parameters there. 

Of course! Thank you Joe, that worked. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×