Jump to content
nicoladanese

meshing slow mo flip fluid

Recommended Posts

hey!

I'm doing a product splash with a slow mo effect. I tried different solutions about how to retime the sim, and I'm pretty happy at the moment with the technique of timeblend / tiemshift. I was also keen on trying the substep caching ( so a more accurate solution, but slow...) . Anyway, as I said I'm pretty happy with the sim, but once I mesh the particles it seems like the mesh is not really consistent across the frame. Is something you don't notice at full speed, but in slow mo is quite important, especially with water where even a little change in the mesh dramatically modify the look of reflections/refractions. So what I'm doing is cranking up the number of particles (reducing the separation...) to get a more precise mesh. But I'm paying this in terms of sim speed...I was wondering if any of you has experience in this topic. I'm also thinking about changing the scale of the scene, is quite big at the moment (geos are from another software), maybe simming this at a proper scale will help

sim_v003_t000.mp4

Share this post


Link to post
Share on other sites

Hi there

 

Nice sim.

I'm having problems with slow mo as well but I've been trying to create the slow motion by running time at a slower speed on the dopnet node. It's possible I've totally misinterpreted the use of this, hope not.

Have you tried that?

 

I have issues because I reference another dopnet so it's not working as I expected it to but it seems like a good idea? - the running dopnet at a slower speed that is.

cheers

Nigel.

Share this post


Link to post
Share on other sites

Hey Nigel

well changing the time scale in the dopnet dramatically change the look of the sim, so I avoid that...after a bit of research I found useful tips on the houdini help for the particle fluid surface

Quote

 

For very slow moving viscous fluids, the default surfacing settings can lead to some "flickering" in the resulting mesh. To minimize any flickering, try any of the following:

  • Turn off Reseed Particles on the FLIP Solver to avoid introducing new particles during the simulation.
  • If using the Average Position surfacing method, turn on Limit Refinement and leave the iterations at 0 or switch to the Sphericalmethod. In either case you will probably need additional smoothing on the Filtering tab, using the Dilate, Smooth, and Erodeparameters.
  • Disable adaptive polygon meshing by setting Adaptivity to 0. This setting will create a heavier mesh, but the mesh will be more consistent over time and avoid variations in the normals from changing polygonization.

 

  •  

following those steps I definitely got a much more stable mesh, with no flickering

  • Like 1

Share this post


Link to post
Share on other sites

yeah I think you need to plan ahead in terms of a time scale value if working that way. i'll post some results when i get chance.

Did you end up being able to capture your fine detail?

cheers

Nigel.

 

Share this post


Link to post
Share on other sites

hey Nigel, well yes I'm pretty happy with the result, I ended up simming at real time and then retime at about 1000% of the original speed (so not a huge slow mo, we work at 25 fps here so my slowmo was roughly 250 fps) you can see that the behaviour sometimes isn't really accurate, especially when a collision happens, but still okay...when I think about the sim I'm surprised on how the time of simming/meshing/rendering is splitted in a (for me). I'm really close to deliver the tv commercial, then I will breakdown it and share the results, it will be quite different from the video I posted due to client requests...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×