Jump to content
Sign in to follow this  
smbell

Trouble getting RSNoise to stick to my packed RBD fracture sim

Recommended Posts

I’ve got a simple voronoi fracture sim with added edge detail (from Jonny Farmfield's example). An object from two Boolean’d spheres falls and breaks on the ground. Everything is working great except I can’t figure out how to get my RSNoise bump texture to stick to my fractured pieces. I’ve tried to do everything suggested from my search results, but it’s not working. I tried to create a vertex UV attribute as well as a rest SOP to no avail. I’m quite certain it’s something simple. Always is.

On a side note, I am creating three point attributes from boolean and fracture groups to pass to my redshift shaders, inside, outside, and ainsideb. This works great and is picked up by RS even though I’ve not specified that the attributes get passed through my assemble SOP. When I do pass them though explicitly they get all jumbled up and don’t correspond to the right points anymore. Does redshift just figure out these attributes on it’s own. They aren’t even listed in the Geometry Spreadsheet yet work correctly. I didn’t want to assume this behavior as it might be messing up other attributes needed for the noise to work.

 

I’ve attached a file.

simple.edge.displace.v7.hiplc

 

 

Edited by smbell

Share this post


Link to post
Share on other sites

I don't have access to Houdini ATM, but did you create UV attribute before or after the RBD sim?

If I'm not mistaken (as I'm new to Houdini as well), I believe you have to create the UV's initially and make sure the attribute is transferred throughout. Also, you can create a separate UV attribute for the inside edges based on that attribute you mentioned from the boolean. I don't use Redshift so otherwise, it could be a redshift thing. You should use the UV quick shader to check the UVs after the DOP network for troubleshooting.

However, on another side note, I've found that adding an attribute called "inside" on the original geo and setting it to 0 with a default of 1 is better for getting inside faces- it makes sure that new geometry always has the inside attribute with a value of 1 instead of depending on the boolean node to do it. I could just be paranoid though.

I'll take a look when I get close to Houdini, but someone more experienced feel free to jump in :P 

Best,

Hunter

Share this post


Link to post
Share on other sites

I had a quick look at your file and the UVs aswell as restpos are alright after the sim.
I don't have redshift either so my only guess is it might have something to do with the attribs being packed away.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×