Jump to content

FR3D

Members
  • Content count

    80
  • Donations

    0.00 CAD 
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by FR3D

  1. I can't make anything follow path correctly, it simply doesnt work or when it works(with a camera) i cannot keyframe the position parameter On null nodes there is no position parameter either What am i missing? EDIT: Thanks to MiesnerMedia 1) Go inside the object you want to constraint to a path 2) create a "constraint (chop network)", go inside and add a path node. 3) select your path object in the SOP path parameter
  2. i am trying to reproduce a ramp sliding effect from vop to wrangle. I used the vop version for very long without issue,i add a parameter before the ramp to move its position(usually used to slide the ramp across UVs) For some reason it seems i am not reproducing the wrangle the right way. you can see the vop in the pic and my attempt at reproducing it in wrangle. i posted the file. script: float ptnum = (float)@ptnum; float numpt = (float)@numpt; float anim = chf("page_animation"); //slider from -1 to 1 float div = ptnum/numpt; float bend_anim = div+anim; float ramp_bend = chramp("ramp_bend",bend_anim); @bend = fit(ramp_bend,0,1,chf("bend_left"),chf("bend_right"));//slider from -90 to 90 book_odforce.hip
  3. Yep it does thank you. Does that mean that in vops it is automatically clamped?
  4. Vellum - animated Pin to Target?

    Hello, thank for the post . After digging on this issue i found a simpler technic that works based on "WHATISANAME" suggestion I modified your file getting rid of all the hassle of the block begin which i can't understand myself, i hope it helps. I upload the clean version i did for myself as well ready to be used test_fur_vellum_v04_SIMPLE.hip vellum_pintotarget_animated.hip
  5. Hello, i am trying to load custom node from my galleries at startup. I know nothing about python I am able to load basic Houdini and Redshift nodes from script found , but after searching i was unable to find the proper script to load nodes from my personal galleries. i tried this to load a custom cam i made for redshift Mycam = hou.galleries.galleryEntries('cam1')[0] cam = obj.createNode("Mycam", "cam_1") EDIT: just figured out that i need to load a preset on the node.
  6. Metadata in wrangle not working

    Thanks a lot for your help. I managed to make it work, but it didn't give a good result, so i ended up using noise, like in Matt Taylor tutorial. Cheers.
  7. recursive_division.hip I am trying to randomise a for each using vex and metadata.i only get 0 as a return. I made it work in another scenarios, but i am unable to find why it doesn't work in that specific case. I used all the different script without success: int i = detail("op:../meta","iteration"); or plugged-in int i = detail(1,"iteration"); See the file attached Thanks for the help.
  8. Metadata in wrangle not working

    yes the issue is that only the value zero is returned, so the random will not happen differently at each iteeration. I just want to use it to randomise the lerp function, so i can animate the cut in different direction(-1,1) with something like that. direction = floor(fit01(rand(@i),-1,2));
  9. Metadata in wrangle not working

    Yes before computing anything i need to be able to bring it in I also realised the issue was because i was deleting the original poly. So i have to rethink the whole thing, i ll try to find a way to store thee value before deleting the poly Thank you anim for answering
  10. I manage to find a realistic way to position a train properly on a track. (see file attached) Wagon cannot simply be copied on an animated point on a curve as the centre is offset-ed in turns realistically. A path deformer is out of the question because of the deforming geometry This is my solution. 1) I created a 2 point line for each wagon 2) I path deformed the result 3) created a single point for each of those deformed line to copy each wagon onto, with proper vector for the wagon alignement I feel it is very complicated and i am curious for a better solution. If anyone interested to give his input. train_realistic_track.hip
  11. I am doing a simple "Flag" asset with materials , texture and object embedded. All work nicely except for the "POP wind" node i place in my vellum solver which disappear when i bring the digital asset. All the rest works without a problem. What am i doing wrong?
  12. I am doing a small rain system. When i add the trail sop, followed by an add to connect the point with the ID attribute, everything works fine until i set the trail increment to a value different than 1, then it completely breaks. I believe it is because particle are dying, but i cannot figure out how to debug it Trail_sop_issue.hip
  13. from the doc: When using a Particle SOP or Spring SOP as input, it is important to keep the trail increment to integer values. Otherwise, the trail will not work well. :(
  14. Hello, For some reason i can't set a keyframe on the position and roll parameter to animate an camera along a path. I works for other param, like transform etc. It has been a persistent issue for a couple of version for me. The issue happens on any object container. Any help would be really appreciated as i am on a tight deadline FOUND A SOLUTION: I added a carve node on the path and animated that instead of the position parameter on the geo. well it works.....
  15. Should we rejoice or be scared for new tech like that. What happens when anyone can do pyro-effect, with a couple of clicks? That said it looks quiet impressive for real time.
  16. I found a clean solution Here is the file. If anyone has a better method that works on broader situations please add to it. thanks confetis.hip
  17. I am trying to blow up multiple groups of particles in a sequence.(boxes of confetti exploding at different times). The activation isn't really the problem as I can use a sop solver within a dop to activate the particles group at different time. The issue is to give them that "initial velocity" at activation time. The only method i found that is working to achieve the effect, was to actually import and merge many popobject and "activate" them one by one in a sequence , with the velocity attribute created at sop level This solution is of course very inconvenient. I attached a clean file, with just the different group all popping at the same time. a solution to have them delayed one after the other would be very welcome I just can't find an elegant method which works procedurally. Thank you for your help confetis.hip
  18. Hello, I would like to know if there is a way to merge my home sop presets with my work sop presets in a simple way. The only solution i came up with for now: Create a file with duplicate of the node with selected presets, opening the file at work and save every node as a preset. It is very inconvenient considering i have tons of presets. Saving to gallery is also very inconvenient at that point. Is it possible to just open the ".idx" file and just copy paste to add presets? Also do you favour save to gallery or save presets per node?
  19. SOLVED 1)you need to create a subnet out of the geometry and the bones all together 2)make sure there is nothing after your deform node on the geometry 3)export the entire subnet as FBX 2014, keep the option as default Hi I scanned forums for hours and didn't find a simple straight answer, neither a simple basic Houdini tutorial as how to do so. Neither on unreal forum, neither here nor sidefx's. -Vertex map texture isn't what i am looking for. -alembic works but i have problem with normals. -i am using unreal 4.17 and i cannot go back to an earlier version at that point. 2)The steps -I am animating an oil pump rig with 3 bones. -I export from houdini via FBX -If i import back in houdini the animation works -if i import in modo, c4d,unreal, there is no animation. -If i export with "export deform as vertex cache" the animation works in c4d but not in modo neither unreal. Thank you for your help oilrig.rar
  20. Power Shot

    hey houdinaughts i am trying to do a full project from scratch all made by me, including the shooting on chroma of the players that will be composited directly in houdini. The concept is simple, a player does a power shot and the goal catch it, it is basically a power trip. -The scene include smoke, rbd, fur, particles i am still working and undecided on the lighting. anyway here is some renders i did today. here is the preview animation: https://vimeo.com/72697674 criticism is very welcome PS: thanks to people who are helping on the forum for your great tips
  21. Power Shot

    Thank you Diego! Well it pretty much died for budget reasons,sadly...
  22. I am trying to animate an engine using chops and constraints. I manage to get something quiet close but it isn't accurate(cheat) My main issue is that i cannot find how to use a "look at" in conjunction with some restriction to force the tip of the arm to slide along the Y axis. I tried many other solution as well as trigonometry(which i am not very good at) which i gave up on. i also tried with bones but again my knowledge is close to none in houdini and i wasn't able to restrict bones I wish to achieve the real thing with your help Thank you piston.hip
  23. Thank you 3dome. I will clean my file, and share it in the days coming.
  24. Ok, i managed to get the trigonometry formula. Now i have two method. one is Hscript which works perfectly(u can check the measure sop) and the other one is VEX. For some reason the Vex(into a point wrangle)works but is speed up.I am pretty sure it is the same script. Does the wrangle node manage "@frame" differently than "$FF" in hscript? piston trigonometry.hip
  25. Mantra shader emission issue

    Hi, It seems i cannot get the emission to work anymore when using a mantra shader or a material shader builder. The object doesn't light up nor illuminate other object. It works fine with principled shader tho. The project i am working on needs object to evolve thru attributes from emitive to refractive If anyone has a tip or a work around it would be apreciated Thank
×