Jump to content

Waasha

Members
  • Content count

    42
  • Donations

    0.00 CAD 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Waasha

  • Rank
    Peon

Personal Information

  • Name
    Vasa
  • Location
    Prague

Recent Profile Visitors

2,159 profile views
  1. F.E.M. stretch using constraints

    Hi everyone! I am currently learning F.E.M. (after avoiding it for years ) and I would like to pin few points of a solid object to an animated position. I saw there is a number of methods (using targetP, targetV, ...) but I was unable to make them work.. The Follow Target shelf tool on Solid shelf works weird, it asks only for the constrained object (my solid object), then for the constrained points (I select them on the solid object), but that's all! It doesn't ask for the object to actually follow! For the sake of simplicity - I created this simple test with two animated spheres and I would like the solid object between them to be stretched (the points of the solid object, that intersect with the spheres should be constrained to the animation of the spheres). I deleted all the "non-working" failed constrained nodes to make it clean. Can anyone point me in the right direction? Big thanks for any help! FEM_stretch_test_V01.hipnc
  2. Hi, I have a problem with FLIP and RBD point object collision. No matter if I select bullet or RBD solver for the collision, some of the RBD objs keep acting very weird.. I tried to increase substeps, on the RBD solver I played with different parameters, but no luck.. Any ideas? FLIP_RBD_point_collision_V01.hipnc
  3. Glue constraint unbreakable by sop force?

    Oh, great, thank you very much for such a quick response, Juraj! I actually knew about this "feature" of hard constrain, but it didn't cross my mind in this situation.. Will try it right away! And thanks for letting me know, that I'm not the only one, who can't break the glue constraint by force. It would be nice, if it would be mentioned in the help.. together with other little details about the constrains. Hopefully in the future Bye!
  4. Hi! I have a hard time trying to break the glue constraint by sop force. Other constraints (like "hard" for example) work like a charm, but glue, even with VERY low strength, doesn't seem to even notice the force.. If I break the "wall" with a rbd collision object before the explosion force happens, it works. In the example please try to disable the rbd sphere and you will see, that it doesn't break by the explosion force on frame 10. I need the glue constraint to keep the pieces in place before the explosion. With just the hard constraint the aren't absolutely stationary, but they are moving a bit. Is there a way to keep them stationary just with the hard constraint? Thanks for any advice! glue_cns_sop_force_test_V01.hip
  5. Flip constant flow through static fluid box

    Just for better ilustration, here is a picture of the problem. When I add a force in +X, the fluid is rising on the border, where it "exits" the fluid box and it's sinking where it "enters" the fluid box. I just need a constant flow from one side to another without any waterlevel changes... Thanks
  6. Hi everyone! I have difficulties with what looked like a very simple setup.. I need a static fluid box and a flip fluid running through it in one direction. Sort of like being emited on one side and being killed on the other. I thought that's what the boundary layer is supposed to do by default, but it doesn't work as expected. I thought if I create a wave tank and give it a different vel field (instead of the ocean vel), it will work, but it doesn't. Attached is my test file. I would be very grateful for any advice, thanks! H13_constant_flow_V01.hip
  7. Flip sim with one sided collisions

    I ran a few tests and I have an update.. There are multiple options I could achieve the desired effect: 1) For my situation all I need is an ability to switch the collision on/off based on an attribute... So I would just sample the collision volume and store 1 or 0 if I'm inside or outside and then switch the collision on/off per particle. 2) I tried turning off the "Use Volume Based Collision Detection" on the static RBD object and with the normals facing out, the "polygonal" collision worked perfectly, but with inversed normals the solver deleted all particles on the first frame (which is logical-they are inside the collision). So maybe it would suffice to turn off the deletion of particles inside of the collision obj.. 3) Maybe I could somehow use the streams layout to affect the sim by the collision based on the groups of particles in different streams.. Right now I don't know which one is the best, or how to do any of them, but will keep testing.. Thanks for any ideas!
  8. Hello everyone! I'm about to start on a new project, where I need the Flip fluid to get "inside" of an object (after floating around it for some time) and collide from within with it. Is there a way to achieve this with volumes? I always use the static RBD with VDB sample collision geo, but I'm afraid it will cause problems, since when the fluid will be outside the object, it will be "inside" of its collision (hopefully that makes sense ) As I said, I will try to solve it myself, but if anyone of you have an idea, how to do it theoretically, it would give me a nice headsup Bye, thanks!
  9. Thanks Skybar, I know about that option, but I really couldn't understand, why that expression didn't work.. And the problem wasn't in the expression, but - as pezetko correctly sugested - in the Group Type selector of the blast node..
  10. Thank you, Peter, I really thought that since there are ONLY points, houdini will undersand I want to work on points, since it's Guess from group P.s.: Mario says - Don't look on Houdini forums during your vacantion
  11. Hey all, just a really quick and simple one. I want to delete based on Cd parameter, that I created with vopsop (I don't want to add a color SOP to have a local variable CD, because it would be slower and I'm working with lots of particles), and I'm unable to do so, because the expression @Cd.x>0.5 doesn't work in the blast SOP.. Can anyone explain me why? Thanks!
  12. FLIP sourcing from VDB

    Ooh, ok... That's right... I was so focused on replicating all the volumes (there is a surface and a vel volume created by the Fluid Source node in the emitor), that I didn't notice a simple fact, that all the points have a v attribute, that is NOT transferred to the points created by the "points_from_volume" node... Sorry for my ignorance.. I just thought the initial velocity for the "shelf" example is working because of all the volumes, but there doesn't have to be any volume at all to source particles with some initial velocity... Thanks again, you made it quite clear for me..
  13. FLIP sourcing from VDB

    Thanks for such a quick reply, anim! I am aware, that I didn't specify the vel field in the source Volume parms, but neither I did for the "classic" way of sourcing the velocity and it works.. I tried to mimic all the field just the way the "classic" fluid source node sets them, so if you carefully look in the emitor, you will see, that I have particles there, and I have both the surface and the vel field, just like with the "shelf tool" situation.. There is no difference in the source concerning the data.. Yet with the shelf tool it works and with the data prepared from VDB it doesn't work.. I just don't understand why? And also I know I can plug source to volume velocity input of the FLIP solver, but that would act as a velocity emission, but not as the initial velocity of the particles, if you know what I mean. You can see the difference in the color of particles at the first frame. If they have initial velocity, they are already lighter (they have some velocity when they are born).. I have some ways to solve it differently, I just wanted to understand, why the same data are not working when made from VDB (try to middle click on both OUT nulls in the emitor geometry, they have the same parameters and fields..) Thanks a lot!
  14. FLIP sourcing from VDB

    Hello, I'd like to ask what is wrong with sourcing initial velocity from VDB field.. Attached I have a scene, which is working fine with sourcing from fluid source node, but is not working with the same field created as VDB fields. To see the VDB version, switch the switcher in the AutoDopNetwork from 0 to 1. Thanks for any idea why it's not working.. init_vel_from_VDB_V01.hipnc
  15. Thank you VERY much for such a detailed answer, danw. In Real Flow this isn't problem, but that's SPH. Now I understand how it works with FLIP.. I will look into the divergence emitting. Thank you very much again!
×