Jump to content

Search the Community

Showing results for tags 'Render'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Lounge/General chat
    • Education
    • Jobs
    • Marketplace
  • Houdini
    • General Houdini Questions
    • Effects
    • Modeling
    • Animation & Rigging
    • Lighting & Rendering
    • Compositing
    • Games
    • Tools (HDA's etc.)
  • Coders Corner
    • HDK : Houdini Development Kit
    • Scripting
    • Shaders
  • Art and Challenges
    • Finished Work
    • Work in Progress
    • VFX Challenge
    • Effects Challenge Archive
  • Systems and Other Applications
    • Other 3d Packages
    • Operating Systems
    • Hardware
    • Pipeline
  • od|force
    • Feedback, Suggestions, Bugs

Found 227 results

  1. Hi, I got myself an old HP Proliant DL380 G7, with dual X5650s, 48GB Ram (Soon to be 96GB) and a bunch of SAS drives, which I am planning to use for rendering next to my WS. My question is, how would I most efficiently use it for rendering if I decide to install Linux on it, while running Windows on my WS? Currently I have all my projects and files on dropbox, but I am considering moving it all to a NAS in my network so that they can both run from that. How would you guys setup that kind of rendering? Does Hqueue support that right out of the box, or would something like Qube! be better? Cheers, Jonas
  2. HQueue Problems

    Hey guys, I am having a heck of a time getting my farm setup for my school finals. I have three machines I need to run sliced fluid sims on. Right now I am just trying to get the main workstation to complete a HQueue job... So I have HQueue client and server installed on this machine on the C drive. Both services run fine under another admin account I created called HQueue. I Have used the shelf tool for creating a sliced sim (pyro sim in this case) as recommended per the HQueue documentation. The shared folder with a houdini install in it is on another disk called F in the workstation, the specific folder is shared as hq to all other machines and is mounted on all of them as H: I have no problems accessing it from any machine. The server's .ini file has been setup with the server ip of the pc it is running on (the workstation), and these lines have been set: hqserver.sharedNetwork.path.windows = \\KYLE-PC\hq hqserver.sharedNetwork.mount.windows = H: Everything else in there is vanilla. The problem seems to be in writing the slice files to the mounted H: drive, as I get this error when I submit the houdini file I have attached: hqlib.callFunctionWithHQParms(hqlib.simulateSlice) File "\\KYLE-PC\hq\houdini_distros\hfs.windows-x86_64\houdini\scripts\hqueue\hqlib.py", line 1864, in callFunctionWithHQParms return function(**kwargs) File "\\KYLE-PC\hq\houdini_distros\hfs.windows-x86_64\houdini\scripts\hqueue\hqlib.py", line 1532, in simulateSlice _renderRop(rop) File "\\KYLE-PC\hq\houdini_distros\hfs.windows-x86_64\houdini\scripts\hqueue\hqlib.py", line 1869, in _renderRop rop.render(*args, **kwargs) File "//KYLE-PC/hq/houdini_distros/hfs.windows-x86_64/houdini/python2.7libs\hou.py", line 32411, in render return _hou.RopNode_render(*args, **kwargs) hou.OperationFailed: The attempted operation failed. Error: Failed to save output to file "H:/projects/geo/untitled.loadslices.1.bgeo.sc". Error: Failed to save output to file "H:/projects/geo/untitled.loadslices.2.bgeo.sc". I am really not sure why this is happening as I think I have all the relevant permissions. Any suggestions peeps? -Kyle Here is the diagonostics ouput too: Diagnostic Information for Job 75: ================================== Job Name: Simulate -> HIP: untitled.hip ROP: save_slices (Slice 0) Submitted By: Kyle Job ID: 75 Parent Job ID(s): 73, 76 Number of Clients Assigned: 1 Job Status: failed Report Generated On: December 12, 2015 01:52:08 AM Job Properties: =============== Description: None Tries Left: 0 Priority: 5 Minimum Number of Hosts: 1 Maximum Number of Hosts: 1 Tags: single Queue Time: December 12, 2015 01:15:04 AM Runnable Time: December 12, 2015 01:46:19 AM Command Start Time: December 12, 2015 01:50:04 AM Command End Time: Start Time: December 12, 2015 01:50:04 AM End Time: December 12, 2015 01:50:18 AM Time to Complete: 13s Time in Queue: 35m 00s Job Environment Variables: ========================== HQCOMMANDS: { "hythonCommandsLinux": "export HOUDINI_PYTHON_VERSION=2.7 && export HFS=\"$HQROOT/houdini_distros/hfs.$HQCLIENTARCH\" && cd $HFS && source ./houdini_setup && hython -u", "pythonCommandsMacosx": "export HFS=\"$HQROOT/houdini_distros/hfs.$HQCLIENTARCH\" && $HFS/Frameworks/Python.framework/Versions/2.7/bin/python", "pythonCommandsLinux": "export HFS=\"$HQROOT/houdini_distros/hfs.$HQCLIENTARCH\" && $HFS/python/bin/python2.7", "pythonCommandsWindows": "(set HFS=!HQROOT!\\houdini_distros\\hfs.!HQCLIENTARCH!) && \"!HFS!\\python27\\python2.7.exe\"", "mantraCommandsLinux": "export HFS=\"$HQROOT/houdini_distros/hfs.$HQCLIENTARCH\" && cd $HFS && source ./houdini_setup && $HFS/python/bin/python2.7 $HFS/houdini/scripts/hqueue/hq_mantra.py", "mantraCommandsMacosx": "export HFS=\"$HQROOT/houdini_distros/hfs.$HQCLIENTARCH\" && cd $HFS && source ./houdini_setup && $HFS/Frameworks/Python.framework/Versions/2.7/bin/python $HFS/houdini/scripts/hqueue/hq_mantra.py", "hythonCommandsMacosx": "export HOUDINI_PYTHON_VERSION=2.7 && export HFS=\"$HQROOT/houdini_distros/hfs.$HQCLIENTARCH\" && cd $HFS && source ./houdini_setup && hython -u", "hythonCommandsWindows": "(set HOUDINI_PYTHON_VERSION=2.7) && (set HFS=!HQROOT!\\houdini_distros\\hfs.!HQCLIENTARCH!) && (set PATH=!HQROOT!\\houdini_distros\\hfs.!HQCLIENTARCH!\\bin;!PATH!) && \"!HFS!\\bin\\hython\" -u", "mantraCommandsWindows": "(set HFS=!HQROOT!\\houdini_distros\\hfs.!HQCLIENTARCH!) && \"!HFS!\\python27\\python2.7.exe\" \"!HFS!\\houdini\\scripts\\hqueue\\hq_mantra.py\"" } HQPARMS: { "controls_node": "/obj/pyro_sim/DISTRIBUTE_pyro_CONTROLS", "dirs_to_create": [ "$HIP/geo" ], "tracker_port": 54534, "hip_file": "$HQROOT/projects/untitled.hip", "output_driver": "/obj/distribute_pyro/save_slices", "enable_perf_mon": 0, "slice_divs": [ 1, 1, 1 ], "tracker_host": "KYLE-PC", "slice_num": 0, "slice_type": "volume" } HQHOSTS: KYLE-PC Job Conditions and Requirements: ================================ hostname any KYLE-PC Executed Client Job Commands: ============================= Windows Command: (set HOUDINI_PYTHON_VERSION=2.7) && (set HFS=!HQROOT!\houdini_distros\hfs.!HQCLIENTARCH!) && (set PATH=!HQROOT!\houdini_distros\hfs.!HQCLIENTARCH!\bin;!PATH!) && "!HFS!\bin\hython" -u "!HFS!\houdini\scripts\hqueue\hq_sim_slice.py" Client Machine Specification (KYLE-PC): ======================================= DNS Name: KYLE-PC Client ID: 1 Operating System: windows Architecture: x86_64 Number of CPUs: 24 CPU Speed: 4000.0 Memory: 25156780 Client Machine Configuration File Contents (KYLE-PC): ===================================================== [main] server = KYLE-PC port = 5000 sharedNetwork.mount = \\KYLE-PC\hq [job_environment] HQueue Server Configuration File Contents: ========================================== # # hqserver - Pylons configuration # # The %(here)s variable will be replaced with the parent directory of this file # [DEFAULT] email_to = you@yourdomain.com smtp_server = localhost error_email_from = paste@localhost [server:main] use = egg:Paste#http host = 0.0.0.0 port = 5000 [app:main] # The shared network. hqserver.sharedNetwork.host = KYLE-PC hqserver.sharedNetwork.path.linux = %(here)s/shared hqserver.sharedNetwork.path.windows = \\KYLE-PC\hq hqserver.sharedNetwork.path.macosx = %(here)s/HQShared hqserver.sharedNetwork.mount.linux = /mnt/hq hqserver.sharedNetwork.mount.windows = H: hqserver.sharedNetwork.mount.macosx = /Volumes/HQShared # Server port number. hqserver.port = 5000 # Where to save job output job_logs_dir = %(here)s/job_logs # Specify the database for SQLAlchemy to use sqlalchemy.default.url = sqlite:///%(here)s/db/hqserver.db # This is required if using mysql sqlalchemy.default.pool_recycle = 3600 # This will force a thread to reuse connections. sqlalchemy.default.strategy = threadlocal ######################################################################### # Uncomment these configuration values if you are using a MySQL database. ######################################################################### # The maximum number of database connections available in the # connection pool. If you see "QueuePool limit of size" messages # in the errors.log, then you should increase the value of pool_size. # This is typically done for farms with a large number of client machines. #sqlalchemy.default.pool_size = 30 #sqlalchemy.default.max_overflow = 20 # Where to publish myself in avahi # hqnode will use this to connect publish_url = http://hostname.domain.com:5000 # How many minutes before a client is considered inactive hqserver.activeTimeout = 3 # How many days before jobs are deleted hqserver.expireJobsDays = 10 # The maximum number of jobs (under the same root parent job) that can fail on # a single client before a condition is dynamically added to that root parent # job (and recursively all its children) that excludes the client from ever # running this job/these jobs again. This value should be a postive integer # greater than zero. To disable this feature, set this value to zero. hqserver.maxFailsAllowed = 5 # The priority that the 'upgrade' job gets. hqserver.upgradePriority = 100 use = egg:hqserver full_stack = True cache_dir = %(here)s/data beaker.session.key = hqserver beaker.session.secret = somesecret app_instance_uuid = {fa64a6d1-ae3f-43c1-8141-9c29fdd9d418} # Logging Setup [loggers] keys = root [handlers] keys = console [formatters] keys = generic [logger_root] # Change to "level = DEBUG" to see debug messages in the log. level = INFO handlers = console # This handler backs up the log when it reaches 10Mb # and keeps at most 5 backup copies. [handler_console] class = handlers.RotatingFileHandler args = ("hqserver.log", "a", 10485760, 5) level = NOTSET formatter = generic [formatter_generic] format = %(asctime)s %(levelname)-5.5s [%(name)s] %(message)s datefmt = %B %d, %Y %H:%M:%S Job Status Log: =============== December 12, 2015 01:15:04 AM: Assigned to KYLE-PC (master) December 12, 2015 01:15:10 AM: setting status to running December 12, 2015 01:15:23 AM: setting status to failed December 12, 2015 01:18:28 AM: Rescheduling... December 12, 2015 01:18:28 AM: setting status to runnable December 12, 2015 01:18:28 AM: Assigned to KYLE-PC (master) December 12, 2015 01:18:35 AM: setting status to running December 12, 2015 01:18:47 AM: setting status to failed December 12, 2015 01:23:18 AM: setting status to runnable December 12, 2015 01:23:19 AM: Assigned to KYLE-PC (master) December 12, 2015 01:23:20 AM: setting status to running December 12, 2015 01:23:33 AM: setting status to failed December 12, 2015 01:29:44 AM: setting status to runnable December 12, 2015 01:29:44 AM: Assigned to KYLE-PC (master) December 12, 2015 01:29:44 AM: setting status to running December 12, 2015 01:29:57 AM: setting status to failed December 12, 2015 01:34:17 AM: setting status to runnable December 12, 2015 01:34:17 AM: Assigned to KYLE-PC (master) December 12, 2015 01:38:17 AM: setting status to abandoned December 12, 2015 01:46:19 AM: setting status to runnable December 12, 2015 01:50:04 AM: Assigned to KYLE-PC (master) December 12, 2015 01:50:04 AM: setting status to running December 12, 2015 01:50:18 AM: setting status to failed UPDATE: I just did a system restart to see if it would help and instead of the regular write error I recieved this: 0x00000000577CDE78 (0x000000000000002B 0x000000AD63AEF840 0x000000AD453FEEB0 0x0000000000000000), ?thread_sleep_v3@internal@tbb@@YAXAEBVinterval_t@tick_count@2@@Z() + 0x8C8 bytes(s) 0x00000000577CDD2B (0x000000AD45381F90 0x000000AD45381F90 0x000000AD453FEEB0 0x0000000000000000), ?thread_sleep_v3@internal@tbb@@YAXAEBVinterval_t@tick_count@2@@Z() + 0x77B bytes(s) 0x00007FFF29E43FEF (0x00007FFF29EE1DB0 0x0000000000000000 0x0000000000000000 0x0000000000000000), _beginthreadex() + 0x107 bytes(s) 0x00007FFF29E44196 (0x00007FFF29E44094 0x000000AD453FEEB0 0x0000000000000000 0x0000000000000000), _endthreadex() + 0x192 bytes(s) 0x00007FFF36582D92 (0x00007FFF36582D70 0x0000000000000000 0x0000000000000000 0x0000000000000000), BaseThreadInitThunk() + 0x22 bytes(s) 0x00007FFF36C29F64 (0x0000000000000000 0x0000000000000000 0x0000000000000000 0x0000000000000000), RtlUserThreadStart() + 0x34 bytes(s) After resubmission, it went back to the usual error mentioned above. untitled.hip
  3. crowd render error

    Hi I have a problem when I am trying to render my cached crowd simulation. If I render the dopimport everything renders fine and I get a bunch of soldiers running around. Though as soon as I write my crowd sim to disk as bgeo or bgeo.gz (either using the ROP or the file node) and read them back in something strange happens. In the viewport everything still seems fine but as you can see in the image it does something strange during the render. If I cache my packed crowd sim to alembic it renders fine but it gets really slow and the file is huge compared to a bgeo sequence. So I would rather fix this problem of rendering the bgeo sequence. If I create any other packed object, it renders fine. It just seems to occur when I try to render a crowd simulation that is cached to disk. I am using H14.0.335 Does anyone know what is causing this and how to fix it? Thanks in advance!
  4. Hey guys I have a curiosity about render, its possible to render just a small rectangle area for a frame which contains the object that is moving and make that way to render all frames? like a per frame crop, to optimize the black render processing for mantra Thanks
  5. Hi All, I am trying to shading a crack on a planet based on the depth of the crack. Since the planet before cracking is just a perfect sphere, I generated a spherical SDF bgeo and loaded it in my shader and do volume sample to get the signed distant value based on P. It all worked fine without motion blur, but when I turned on the motion blur to get camera motion blur the render result went wrong like the signed value is offseted. I am not using geo time motion blur or geometry velocity motion blur, just Xform time motion blur to get the camera motion. I have no idea how to fix that or is there a better way to color the crack without motionblur freaking out. I know it works in sop level but I need more detail so I try to move it into shader. I attached here my result render and one simple test I did to show the problem. Hope you guy could help me out and thank you in advance. This is a test render without motion blur, you can see the color separation clearly: This is a test render with xform motion blur, the blue color in crack invaded in the sphere also, creating an interesting but unwanted result: Please check my hip file, just use the rop inside the geo1 to write out the sphere volume then you can render to see the problem. You can try frames between 2-48 which has camera animation. The first frame render is correct since the camera haven't moved yet. I noticed if you just wrote out the volume, the attribute vop node in sop level may not update correctly, the render will be fine but you can try save and close then open the hipfile again to see the result, not sure if it is a minor bug of houdini or what. Again, any input would be helpful, thanks! test_volume.hip
  6. I know this has been asked a few times already but i've not found a very conclusive answer.. At work we currently have one Houdini FX license (locked to my machine) and we would like to test out using some of the other machines for rendering and simulation in the most cost efficient manner. Am I right in thinking we can use my machine as a workstation license and also as the Hqueue server machine? And then we would need Houdini Engine licenses for the render farm machines for rendering and simulation? But the Houdini Engine plugin that comes with Maya is not the same as a Houdini Engine license? And we already have unlimited mantra nodes that came with my FX license so we can just install them on the render farm machines? Is that correct? Have I missed anything?? Cheers
  7. Hi Actually, I have a question about a rendering hope that I can get a answer for that. so the question is kind a simple, let's say I have to render bunch of objects and also it include curves which is import from maya. the thing is I need render without curves, so that I only get objects render. so Is there any possible way not render only curves but only objects? since I have lots of nodes, so... I can't type every single node into excluded object in Mantra... Thank you! =)
  8. Hey guys I have some issues with microvoxel rendering I using 8x8 sampling and volume quality 1 even with this parameters I got the frame flicking, its like density randomize at some places of the clouds. there is some parameters to tweak to get much better frame by frame consistency?
  9. Render Statistics?

    Hi, I'm just starting to get into Houdini, and of course am blown away by the possibilities it offers. Really kind of a grown up software, 3d as it should be.. One question tough for now: As I'm coming from Max I'm accoustomed to have detailed statistics when rendering (e.g. how long takes one frame, polycount, prognostic total render time,....), which H doesn't seem to have out of the box. I know H is made mainly for professional environments with seperated departments, but as an individual artist such a renderstatistic would be really helpful, so does there exist something like that? Thanks, Best Jan
  10. MIKKEL Houdini R&D Reel 2015 - Alot of work in progress, unfinished shots and tests, enjoy
  11. Hi, I (think I) have a problem with my far clipping plane. My render doesn't catch the objects in the back while I do see them in my viewport. I am aware of the 1 to million ratio that I can't exceed, but my objects are about 70 units away so I don't see why that should be a problem. Help:(
  12. Hello, My computer is powerful but nothing ridiculous and I lack a farm to send jobs to. I was wondering if there was a way to automate setting off a hi simulation and then do a render straight after? I would like to work on a low quality iteration during the day, nail the behaviour, look and then set things off over night to simulate and render. Any pointers would be really appreciated Thanks
  13. HI everybody. I'm experiencing a nasty inconsistency between the viewport and render when trying to set the near and far clip of a camera. I've also managed to reproduce the problem with Houdini14 but not with Houdini12 (infact the 12 doesn't give any problem). In the first pic you can see how the scene is setted: a very basic one, some cubes in a row and the camera above them. In the second image I've clipped the view trying to include only the 2 middle cubes. But when I try to render the scene I get something completely different Infact in order to render the scene correctly in the viewport as I want I have to double the parameters of near and far; obviously this gets translated into a wrong result for what concern the render. The parameters in this case are near 20, far 32 for a correct result in the viewport; near 10 and far 16 for the correct result in the render. Obviously what I want is to get them right with the same settings (the correct ones are the render ones) Is there some setting that I'm missing? Here is the simple scene test_clip.hip Thanks in advance test_clip.hip
  14. Hi, I want to output a pass with the shadows that are casted on an object that is matte in my beauty render. Since I can't think of a way to force matte and phantom objects in each different image plane, I created a second mantra node to output just the shadow pass, which works fine. But is there a way to disable the primary beauty render on that second node, so I don't render unnecessary images? I just want the extra AOVs from that render node. thank you Georgios
  15. M getting following error in log after launching render, /houdini/python2.7libs\\hou.py", line 42828, in load\n return _hou.hipFile_load(*args, **kwargs)\n', 'OperationFailed: The attempted operation failed.\nUnable to open file: Z:/filePath/FileName.hip Can any one help me with solving this issue!!! Thanks in advance. note: 1. m using houdini 13. 2. M trying to launch render in farm, local machine its working fine. Only difference between farm machine and local machine is graphics card.
  16. Rendering Fractal Clouds

    Hey , i've made the cmivfx houdini fractals tut and made clouds, but i'm having problems with the rendering time. can anyone help me with that?
  17. Hi all: I am trying to integrated H14 with my company's render pipeline, I imported my old customized Mantra and Rop output Nodes from H13 which were python script HDA module in type property and modified from H13 original nodes, so we could send the geometry cache and renders to the farm with one click. Rop Output Driver: After imported the otls, it will automatically create a new vex type digital asset, and my old one gone. So I tried to modify the H14's built-in Rop Output node in type property, adding the HDA module, after I pasted my script and click accept, same shit happened again, H14 create a new vex type digital asset. It seems H14 forbids user from modifying its built-in nodes in type property. Mantra: I can't even edit anything in type property not without destroying the layouts, so I created a new output driver digital asset, but new render nodes can not be seen in the IPR render view. Do you guys have some ideas how to work around the situations? Orz.................... Thanks
  18. Hi Can someone shed some light on how to render a velocity pass, from a flip fluid vdb mesh, for compositing? Here's a reference videos:
  19. pre-fractured glass render

    Hi there, I'm trying to shatter glass with prefracturing via voronoi. So far so good. I know that the common use to prevent rendering the seams of the prefractured glass is switching from a non fractured to fractured geo within 2 frames. But is there another way to render the prefractured glass as a solid piece? Tried transfering Normals from the unbroken object to the prefractured object but that didn't do the trick.
  20. Hi there, I am trying to integrate a simple box into a photograph that I found on the web. The idea was to just experiment with matching lighting and shadows. In my scene, I have created a grid for the ground, and roughly lined it up with the objects in the photopgraph. I then placed a box on top of the grid and used a distant light, and an environment light to light the scene. I applied a shadowmatte to the ground plane to catch any shadows occurring on it which has given me a nice alpha channel in which to composite shadows. My problem is that in the scene, the dog is casting shadows with a slight blue tint to it. I would like to match my box shadow color to the dog's shadow color. I understand that I can apply a color to the environment light to match the color temperature of the photograph, thus matching the shadow colors too, but obviously this won't work with the shadowmatte as it contains no color information. Obviously if I were casting shadows on a mantrasurface or similar diffuse surface I would get the proper colors of the shadows, however I would like to achieve this effect using the photographic backplate. Is there any way of achieving this with shadowmatte or AOVs, inside Houdini? Or does this need to be faked in compositing? What would be the best approach to this simple object integration? Any help would be really appreciated! W. shadow_test_04.hipnc
  21. Hey guys I've been exploring hython in-depth and I'm wondering if there is a way to capture the render statistics of a file and write it to a file. At the moment my only solution is running something like: hython myscript.py > mylog.txt However, I want to write the file from within the script and not redirect the output of the command from the shell. In my script I'm just doing something like this: import hou rop = hou.node("/out/mantra1") rop.render() # I need the output of this function Any help appreciated thank you guys!
  22. Hello guys I need some help. I am trying to get a nice tail for the marbles in this DOP simulation. Under the Geometry node "Geometry Velocity Blur" us checked and in the Mantra node I am enabling to render Motion Blur. Is there a way to re-calculate the direction of the blur based on the particle's velocity? Cannot figure out why the direction of the blur sometimes is even perpendicular to the velocity vector! Here is the video: https://vimeo.com/112666106 Any suggestion? Thanks a lot guys!
  23. I am trying to instantiate a delay load geometry with different materials properties. so I have a point cloud and I have 1 material node pointing to the delay load and overriding the file property, and works now I can instantiate a delay load (in my case is just a sphere.bgeo) but now if I add another material and I point at a regular shader and over ride the properties so each sphere have different color. because the shop_material of the delay load is fighting with the shop_material property of the shader, I just get one or the other =(... is there a way to fuse the shop_material?
  24. after many days and nights, after many emails, discutions, crying to the moon, etc... thanks to everyone that helped create the tool, between coments, ideas, hints on how to do things, coworkers, the guys in the forums, Sesi, etc... here is the first Beta!!!! https://www.sidefx.com/index.php?option=com_forum&Itemid=172&page=viewtopic&t=34347
  25. we are urgently looking for people familiar with houdini mantra rendering. - junior houdini artists that like to render - senior mantra artists for an animated TV series production based in vienna Austria please go to talent.arxanima.com or send email to talent@arxanima.com subject: houdini rendering we are based in vienna austria so european work permit is a big plus pls let us know where you are from and if you have euro work permit
×