Jump to content
few_a_fx

Help with run an RBD simulation with Low RAM

Recommended Posts

I'm trying to run a rbd simulation where a window unit breaks; however the sim keeps crashing around frame 100, so I'm not able to fully bake or even see how the final animation looks. I had a similar problem with a particle fluid animation, I just lowered the particle count. It worked, but the water doesn't look as well as it should. I plan on compositing the final animation into a live action plate, so I need it to look as real as possible. Any suggestions on how to run/bake the simulation without it crashing due to not enough memory? I have a PC with 6g RAM, running windows 32 bit.

Share this post


Link to post
Share on other sites

You really need to run Win 64 bit with Houdini 64 bit. With 32 bit you aren't even using all of your ram. 6GB is pretty low as well -- ram is cheap!

For some perspective, the machine I use at work has 32GB and I run out sometimes. However that is mostly from multiple sessions and mistakes ...

Edit: Sorry, I don't know how to reduce memory usage on an rbd sim, maybe ODE would be more efficient? how about less divisions on your collision volume, hide everything you don't need in your scene, get rid of attributes in your scene, running houdini from the command line will give you more memory to work with too...

Edited by sam.h

Share this post


Link to post
Share on other sites

I have a PC with 6g RAM, running windows 32 bit.

So you're not using upper 3GB of RAM at all. Get any x64 system first. Easiest way is to install any human-friendly Linux, like Ubuntu. Additionally:

WindowsVista ~= 700MB of RAM

Ubuntu 9.1 ~= 140MB of RAM

Ubuntu 9.1(no X server running) ~= 70MB of RAM

empty session of Houdini 11 with GUI ~=140MB of RAM

empty session of Hbatch 11 (no GUI) ~= 40MB of RAM

Also tuning cache setting of your simulation may help. I can't check it for sure now, but turning on explicit cache on DOP network should save you some RAM.

Edited by SYmek

Share this post


Link to post
Share on other sites

Right now I can't afford a 64 bit system, will switch when able too. Anyways thanks for the tips. I'll try out the cache, command line and ODE stuff. Thanks.

Share this post


Link to post
Share on other sites

Using the explicit cache seems to be working. I can finally see whats going on. Going to try and run it through the command line, so it sims while I'm at work. Will keep you updated. Thanks again sam.h and SYmek

Share this post


Link to post
Share on other sites

Just make sure you have plenty of hard drive space to cache to. Also, if you are going to rely on caching heavily, an investment in a low seek HDD or a 32gb SSD would be very beneficial. I know that in my next system, I am going to be putting an SSD in that I will use for nothing but caching simulations and geometry. The last thing you want to have happen is to be caching a detailed sim and run out of space.

Share this post


Link to post
Share on other sites

Just make sure you have plenty of hard drive space to cache to. Also, if you are going to rely on caching heavily, an investment in a low seek HDD or a 32gb SSD would be very beneficial. I know that in my next system, I am going to be putting an SSD in that I will use for nothing but caching simulations and geometry. The last thing you want to have happen is to be caching a detailed sim and run out of space.

I just got a new hard, 1TB. So I'm ok on that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×