Jump to content
Sign in to follow this  
ioscat

H12: Linux vs SpaceBar

Recommended Posts

Hello everybody.

I have a problem with H:12 with navigating in viewport by holding SpaceBar. It has a delay about 1 sec before navigation starts. Had anybody ever got this trouble?

In addition I can say that multiple press Spacebar results in multiple delays.

/sry for English/

Edited by ioscat

Share this post


Link to post
Share on other sites

OS: Fedora 16

Graphics: 01:00.0 VGA compatible controller: nVidia Corporation GF104 [GeForce GTX 460] (rev a1) (prog-if 00 [VGA controller])

Flags: bus master, fast devsel, latency 0, IRQ 16

Memory at f6000000 (32-bit, non-prefetchable)

Memory at e0000000 (64-bit, prefetchable)

Memory at ec000000 (64-bit, prefetchable)

I/O ports at af00

[virtual] Expansion ROM at e8000000 [disabled]

Capabilities: <access denied>

Kernel driver in use: nvidia

Kernel modules: nvidia, nouveau

/I'm completely new in Linux so I can't figure out which string is needed/

H:12.0.595

/Same trouble in 11.1.118/

Share this post


Link to post
Share on other sites

Hello everybody.

I have a problem with H:12 with navigating in viewport by holding SpaceBar. It has a delay about 1 sec before navigation starts. Had anybody ever got this trouble?

In addition I can say that multiple press Spacebar results in multiple delays.

/sry for English/

hi ,

you didnt mentioned ' how big the geometry is ' .

my workstation had a similar behaviour with some ' heavy ' geometry recently .. ( quadro 2000 )

i considered that ' normal ' .

Share this post


Link to post
Share on other sites

It seems not to depend on heaviness of geometry at all. Delay/Lag takes place even without any geometry in new window.

We suppose Linux tries to perform something when SpaceBar is pressed, but our search didn't give any solution.

Share this post


Link to post
Share on other sites

It seems not to depend on heaviness of geometry at all. Delay/Lag takes place even without any geometry in new window.

We suppose Linux tries to perform something when SpaceBar is pressed, but our search didn't give any solution.

Which Nvidia driver? Did you install it manually? Where did it come from?

Share this post


Link to post
Share on other sites

admin made all job, can i find this information myself in my pc?

Run 'nvidia-settings' from the shell, it'll tell you all you need to know about your graphics system.

Share this post


Link to post
Share on other sites

Thanks a lot!

NVIDIA Driver Version: 295.33

NV-CONTROL Verson: 1.27

The driver version looks ok to me.

You can also use the Spacebar to pan in the network view without picking any nodes - do you get the same sort of lag when you do that?

Share this post


Link to post
Share on other sites

Network view seems to work nice. Maybe it lags from time to time but no so noticeably and not repeatebly.

Share this post


Link to post
Share on other sites

If you can change the distro, try Ubuntu. Houdini works like a charm. Maya also seems to work better in Ubuntu then CentOS and Fedora.

Share this post


Link to post
Share on other sites

I had the same problem with fedora 16. I don't think its the graphics card alone, because I didn't have any lag at all if I didn't use spacebar to navigate the viewport (escape key over the viewport to get to the camera nav tool then it worked fine for me).

I couldn't solve the problem and switched to Sabayon which works really good for me.

I would really be interested why fedora behaves that way.

Share this post


Link to post
Share on other sites

I have the same problem. Fedora 17. On ubuntu everything is fine, but I like Fedora and do not want to move to it. I think it can be configured gnome? Can anyone else come across or know a solution to this problem?

Share this post


Link to post
Share on other sites

Personally, this sounds like a graphics driver issue to me. eg. make sure you're using the closed source drivers? also turn off compiz, etc.

Share this post


Link to post
Share on other sites

Is this related to the issue where when you press space over the viewport, Houdini doesn't trigger navigation? It still thinks the parameters pane is in focus for instance. So pressing W over the viewport, actually opens up the Object Tree List inside the parameters pane :(

This is on windows though.

Share this post


Link to post
Share on other sites

Sorry for my bad English. Fedora 17, graphics card NVidia Quadro FX580, driver version NVIDIA-Linux-x86_64-302.17. Navigation in the viewport is normal, no problems at all, except for the fact that the SpaceBar works with some delay (and if a few times quickly to press, have to wait some time). A trifle, but a unpleasant. I'm new in Linux, and I want to know whether there is a similar problem with other users Fedora or I need to blame my lack of experience))

Edited by rus_n07

Share this post


Link to post
Share on other sites

Hi,

I had the same exact problem and it was VERY annoying, and had nothing to do with graphics card or OS ... causing the problem was the MOUSE.

Microsoft wireless mouse to be specific.

sorry I can't be more helpful (I changed mouse) but worth checking!

my 0.02c

Share this post


Link to post
Share on other sites

I am currently using Fedora 17 with the KDE Desktop and I dont't have the navigation lag. Everything works as it should as long as you can live with KDE. If I switch to gnome the lag problem occurs again both in a clean install or if I have both desktops installed in parallel.

I suspect that it is some strange config in the x server, but currently I am not able to tell more. I reported this as a bug quite a some time back and it was acknowledged as one. But until now there is no solution for this.

I'll keep digging and let you know what I find.

Share this post


Link to post
Share on other sites

It seems crazy but I have solved this problem on Frdora 16 by INTALLING Compiz. Yes, I didn't need it and Metacity was fine for me. Yes I've tried to configure Gnome, Metacity many times to solve this Space lag. But only Compiz has helped.

Interesting that there were no such a lag on the same machine on CentOS 6 which is similar to Fedora.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×