Jump to content
jumper

billowy smoke - fast initial velocity - dots!

Recommended Posts

Hey,

I have a simple setup of sphere emitting smoke I used the billowy smoke shelf tool. The Sphere has a initial Y velocity of 3 set on the fluid source sop. I then multiply the velocity in the autoDopNetwork/source_density_from_sphere/Scale Velocity by 400. I know this is very extreme! But I need a lot of initial force... At this speed I get a lot of small dots appearing near the source/emitter. Is there a way to smooth these initial dots out at these high speeds?

Thanks

Stephen

post-5443-1338325250_thumb.jpg

Share this post


Link to post
Share on other sites

First the problem. You are pushing the smoke a huge distance with large velocities. How do you expect the sim to deal with pushing smoke a few meters in a frame? Not very well of course. You need to supply more substeps.

The best way to do this imho is to increase the Max Substeps parameter in the advanced tab of the Pyro Solver. In my test case with an initial velocity of 100 m/sec, just increasing the max substeps to 2 helped a lot.

The solver uses the CFL predictor to decide when to start substepping beyond the min substep parameter. The help is lifted from the RBD help and is not correct here as it speaks of voxel collision penetration but substitute collision with density and you get a rough idea as to what is happening. The value for the CFL predictor is the voxel distance that the velocity pushes the density across. If that voxel distance exceeds the CFL value, then you start increasing the substepping.

With a max substep value of say 5 and you set the cfl predictor to say 10 and the substepping will start later but provide more substeps for parts of the simulation that are moving very fast.

  • Like 5

Share this post


Link to post
Share on other sites

Hi Old School,

Thanks for the reply. Yes I have been playing around with substeps, but I was wondering if there was possibly another solution .... maybe some kind of blur on the the density for just the initial frames where density starts to appear at the emitter.... but I am not a dop expert so not sure if that is at all possible.

Cheers!

Stephen

Edited by jumper

Share this post


Link to post
Share on other sites

Hi

I have a similar problem but from the other side.

Object moves fast and have following problem:

substep.jpg

I thought it might be solved by substep but this does not help.

I know that the problem in the emitter, but even when I did blur problem still present

Someone can help?

Edited by Ostap

Share this post


Link to post
Share on other sites

Hi

I have a similar problem but from the other side.

Object moves fast and have following problem:

I thought it might be solved by substep but this does not help.

I know that the problem in the emitter, but even when I did blur problem still present

Someone can help?

How are you animating the object? If it is by $F make sure to use $FF. Otherwise sub-stepping the pryo simulation won't help.

  • Like 1

Share this post


Link to post
Share on other sites

Ostap, look at the Fluid Source SOP's Motion Blur tab in the Scalar Volumes tab.

Here you will find the controls to streak your emitter. Increase the Frames To Blur parameter to 2 as a minimum and increase the number of Geometry Samples to copy/streak your emitter over the frames. This is a good strategy to reduce this effect with fast moving emitters.

That and make sure that you use $FF in place of $F if that exists.

Share this post


Link to post
Share on other sites

Thanks guys for help!

The problem was solved when I remembered that the source was written to disk like cache.

Can I somehow use the cache when substep is increased ?

Thanks.

Edited by Ostap

Share this post


Link to post
Share on other sites

Hello guys

I have similar problem. I dont want to increase substeps on AUTODOPNET so I`m trying to find way how to fix it. I have particle system and copy some objects. But fist couple of frames is really fast. I try add timeblend after geometry, try Motion Blur tab under Density Volume SOP (frames to blur 2, Geometry samples 4 for this test) but no good results at all. Any tips?

here is my LowRes test:

scene file:

strips.hip

Share this post


Link to post
Share on other sites

You are using the motion blur settings in the Fluid Source SOP but what is letting you down is the fact that the Particle POP simulation can't cache it's result if you don't wrap it up inside a DOP network. As the Fluid Source SOP steps back to previous frames to compute the trailed volume source, the POP network doesn't return a result as it simply returns the last frame simulation results.

The fix is to insert a Trail SOP immediately after the POP Network SOP and set both it's Trail Length and Cache Size to be the same as the Fluid Source "Frames To Blur" parameter. I used a channel reference and it works fine. I then cranked the Frames to Blur up to 4 and the number of samples in-between to 10 and it fills in the gaps nicely.

  • Like 5

Share this post


Link to post
Share on other sites

You are using the motion blur settings in the Fluid Source SOP but what is letting you down is the fact that the Particle POP simulation can't cache it's result if you don't wrap it up inside a DOP network. As the Fluid Source SOP steps back to previous frames to compute the trailed volume source, the POP network doesn't return a result as it simply returns the last frame simulation results.

The fix is to insert a Trail SOP immediately after the POP Network SOP and set both it's Trail Length and Cache Size to be the same as the Fluid Source "Frames To Blur" parameter. I used a channel reference and it works fine. I then cranked the Frames to Blur up to 4 and the number of samples in-between to 10 and it fills in the gaps nicely.

 

Has this technique changed at all in H14 or is there a different workflow for pyro volumes?  I don't have any experience with the Fluid Source SOP, but after taking a look around the Source Volume SOP in my pyro sim I can't seem to find anything related to a "Frames to Blur" parameter. 

Edited by borbs727

Share this post


Link to post
Share on other sites

@borbs727 You probably figured it out but here's a reference to another thread that shows the trail setup. 

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×