Jump to content
kni8_2k

MicroPolygon Vs Raytraced Artifact

Recommended Posts

Hi there,

I was wondering if any one else has run into this issue.

I am baking tangent normals form a displacement onto a another object.

When rendering in Micro Polygons vs Ray tracing I get an artifact, gray horisontal and vertical lines.

I was wondering if anyone else has come across this and knows of a way of getting rid of it.

My geometry is pretty simple. its two grids. one with a displacement map, and one with the ray sampler for getting the tangent uv's.

I've attached an image of a close up.

let me know your thoughts.

Cheers, and I appreciate the help.

Ali.

post-522-0-93049500-1351190374_thumb.jpg

Share this post


Link to post
Share on other sites

Its not the Displacement bounds. I've already set that pretty high, and the geometry has True displacement and Re-Dicing on. I also turned off variying Ray Samples to get rid of some more artifacting and upped the pixel samplesw from 3 to 16. The image is now pretty clean but will only work in ray traced mode W/O uv Rendering. So I have to manually Place a camera and point it straight down at a grid.

Micropolygon rendering still gives me really bad results with lots of horizontal and vertical artifacts.

Another thing you can see is a 16x16 Tiles which I think are the Render Tile size that is standard in a mantra render.

Share this post


Link to post
Share on other sites

Attached is the latest render.

Could not get the Attachment with out the full post reply wndow.

<- Noob.

:-)

post-522-0-41093300-1351204144_thumb.jpg

Share this post


Link to post
Share on other sites

Solved.

This was finally fixed by changing the Ray Tracing Acceleration model from KD-Tree to Bounding volume.

This also solved my Tiles issue.

Hope this helps someone.... one day.

cheers.

Ali.

post-522-0-59112100-1351206504_thumb.jpg

Share this post


Link to post
Share on other sites

UnSolved. Can't seem to get rid of the damn Tiles.

they are not there at 1024 but are there at 2048 Res.

Share this post


Link to post
Share on other sites

What is your Shading Qaulity and Dicing Flatness? You find both on the Geometry object -> Rendering -> Dicing Try doubling the Shading Quality and lower the Dicing Flatness.

Share this post


Link to post
Share on other sites

Skogen,

No I am not using mantra Subdivisions. Should I be ?

heiligeslama,

Dicing Flatness is at its default 0.05 and the Shading Quality is 2 on the geometry and 2 on the mantra rendering node.

I will try lowering the dicing flatness.

But the shading quality is already really high.

Share this post


Link to post
Share on other sites

unfortunately Dicing Flatness did nothing in the renders.

I went from 0.05 to 0.01

Share this post


Link to post
Share on other sites

I think this may be a bug if anyone else can verify.

When rendering UV textures bake. I get some bad triangles in the render as in the image below.

They appear in micro polygon and Ray trace renders.

this polygon happened to be on the far side of my camera. but I am rendering with UV texture object in the mantra node.

To fix this issue, I changed the Z importance from 0 to 1. (?!?!?!?)

I don't really understand why this makes a difference when doing UV Bake renders. I feel like Mantra should do a better job at setting some variables up when rendering in specific modes.

thoughts, Bug, am I crazy...?

cheers.

a.

post-522-0-04264000-1351292053_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×