Jump to content
Sign in to follow this  
infinity_spiral

Edit SOP after PointCache?

Recommended Posts

Today I faced this problem and while I am thinking for solution I wanted to ask here . The idea is to deform geometry (using edit SOP) after point cache and keep the deformed shape during the animation?

I am attaching a file with simple scene that shows the problem.

Thank you!

Share this post


Link to post
Share on other sites

91 views and nothing. I hope I didn't ask something stupid....or maybe my question wasn't clear enough.I am sorry if it wasn't .

What I want is to add to the existing vectors on the geometry (by using edit sop ) witch means deforming without multiplying by the normals of the geometry, and somehow to preserve the new edited shape during the underling pc animation. I want this to be entirely in VOP. Today I had some time and I tried to play in VOP by storing rest pose for the deformed mesh and then using it's N and P and do some math but still stuck on the math part :)It has to be a way I just can't give up

Than I remembered that I saw some time ago how Brian was using attribute reorient and storing vector attributes to point .So here is an example that uses Brian's method. :)

But I still want to find a way to do it entirely in VOP.So if someone has any ideas will be great.

Thanks.

EditAfterPC_solution01.hipnc

Share this post


Link to post
Share on other sites

Thank you for the example.Actually this was the first thing I tried and didn't work for me .Now when I play with it it seems that somehow edit SOP it doesn't take the last modification into account and maybe that is why I gave up.Maybe I am doing something wrong.How yours it's working is the question ? :)

Again the idea is that this is alembic point cache, so I am using time shift node to get static geometry as reference.

And BTW I still eager to find a way to do this in VOP....just for learning purposes :)

Here is the same setup in this case doesn't work.What I am doing wrong?

EditAfterPC_hm.hipnc

Edited by T.I.M.

Share this post


Link to post
Share on other sites

Yes, you need to "commit" the change into the SOP for this to work. I'm not sure whether this is a bug or not, log it anyways. :) So in your file, where you have it not working, I just click on the "Commit Transform/Peak Changes" button on edit2 to get it to work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×