Jump to content
Zidhjian

Smokeless flame not rendering correctly

Recommended Posts

Hi Ive tried everything to get a decent fire looking render, and now Ive tried using the smokeless flame, but I don't seem to get a correct render at all. Here is a few pictures to demonstrate the difference between the viewport and the renderer. Also if there is anyone who knows how to get a good starting point in shading realistic fire I would be more than happy to hear your input. Thanks!

post-9453-0-24640300-1366258677_thumb.jp

post-9453-0-90832400-1366258679_thumb.jp

TESTING.hipnc

Share this post


Link to post
Share on other sites

Haven't had a look at your file yet, but it probably it's because when you create a smokeless flame, there's no Density volume.

I've been going aroudn this problem just by renaming the temperature field to density, and that's it. :) Of course modify your shader accordingly to pick up "density" instead of "temperature" in your fire shading tab :)

Share this post


Link to post
Share on other sites

I experienced a similar issue and just tweaked the default Pyro shader to get what I wanted instead. I saved out my parameters to a preset, hopefully they help.

Btw. how do I open this preset? :)

Share this post


Link to post
Share on other sites

Btw. how do I open this preset? :)

Drop it in your Houdini $HOME folder, typically in "My Documents" on Windows. On other platforms it's usually called "houdiniXX.X" at the root of the home folder for the user.

Share this post


Link to post
Share on other sites

This by the way is a specific problem with 12.5. The shader worked perfectly well in 12.1 and below. Seems to have had some changes with it. :)

Share this post


Link to post
Share on other sites

Isnt this because mantra expects density for the volume quality calculation?

If you add and change the new vm_volumequalitychannel to something like temperature it seams to render just fine.

Share this post


Link to post
Share on other sites

I don't get it to work, Ive tried everything, changed all the fields in the pyroshader to something else etc. etc. what am I doing wrong?

Share this post


Link to post
Share on other sites

You guys, you DON'T have to change the field inside the shader. That DOES NOT WORK.

As explained, Mantra expects a density field to make the pyro shader work. If your sim doesn't have that, no render - simple.

You have 2 options for now:

1- What Mawi has suggested. Dive inside the shader and change the parameter that the renderer expects to calculate quality (<-cleaner technique, thanks!)

or

2- My solution which is just rename the temperature field to be the density field.

If you go with (2), you don't do this change in the shader. What you've basically done was trying to tell the shader to evaluate the fire/density using different fields. That's just how it will look.You'll need to go in your SOP object with the sim, drop a "name" node, and rename "temperature" (or heat or whatever) to "density". Now use "density" in your shader for the fire field.

Edited by Akabane

Share this post


Link to post
Share on other sites

1- What Mawi has suggested. Dive inside the shader and change the parameter that the renderer expects to calculate quality (<-cleaner technique, thanks!)

Well my suggestion was to add the mantra attribute vm_volumequalitychannel on the mantra node (or the object node?) and set it to the field you use as fire density.

However someone more involved in rendering will have to fill in if this is a valid solution...

Volume quality channel parameter allows you to cull empty volumes based on a field other than density.
Edited by mawi

Share this post


Link to post
Share on other sites

Hmmm... And where can I find this vm_volumequalitychannel? And where do I change the fields in the shader? You mean in the tab fire->density and change the field temperature to density? That doesn't work for me at least.

Share this post


Link to post
Share on other sites

I also discovered when unchecking a field in the import_pyrofields node I also get something different.

Share this post


Link to post
Share on other sites

I got the smokeless flame working somehow and here is how i did it.

1) In the Fluid Source node I added another volume called "density"

2) In ImportPyroBuild turn on Import Option for Density.

3) In Import Pyro Build I added a VolumeVOP after the DOP I/O

4) In the Volume VOP I added the Temperature to the Density (density was Zero). Wanted to assign temp value to Density. Instead of Add you can use Mix with bias 1.

5) Lastly in the Pyro Shader under Smoke > Density set:

Field Name = density

Under FieldShapeTab set Target Range to 0 to 0

I have provided snapshot of all the 5 Steps below:

houdini_Setting_Volume_zps156cb533.png

houdini_ImportPyro_DOPIO_zpscf8f1ea4.png

houdini_ImportPyro_zpsa363bc58.png

houdini_ImportPyro_VolumeVOP_zps09df0a87.png

houdini_Setting_PyroShader_zps4b6036cf.png

Edited by Sapam

Share this post


Link to post
Share on other sites

as it was mentioned just add Volume Quality Channel rendering parameter to your material or object and set it to heat or temperature instead of non-existent density, no alterations necessary

or as Zidhjian mentioned uncheck import of fuel volume as that seems to be used to cull volumes because density is not present, if you not import it other channel will be used

Share this post


Link to post
Share on other sites

Unchecking Fuel Works. I was wondering which field Zidhjian unchecked, as he didn't mentioned that. Thanks for the Info.

Thanks,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×