Jump to content
Neo222

Clipping Happening Within FLIP Container

Recommended Posts

Hi guy,

I am currently creating an explosion effect underneath water using FLIP fluids. So there would be lots of water thrown up in the air very quickly, however I am encountering an issue. There seems to be some sort of clipping going on within the fluid container. I have attached a couple of images so you can see what I mean, it also seems to be worse the lower I have the separation set. Does anyone have any idea what could be causing this and how to stop it from happening?

Thanks in advance

post-9545-0-42804200-1372151610_thumb.jp

post-9545-0-77052600-1372151699_thumb.jp

Edited by Neo222

Share this post


Link to post
Share on other sites

Hi!

What it is is the fluid container boundaries (I think)! You appear to be using a Flip Fluid Tank and if you notice you have a (kind of) wireframe box that clips the fluid (it also manages to avoid it from spilling all over which is good...)

In your DOP network, if you go to your fliptank node, on the Initial data, scroll down and you'll see the closed boundaries option, that is responsable for that...

How you can increase the size of it... that's something I also want to know so maybe someone can explain it to us (sorry for hijacking your thread slightly!)

Cheers!

Share this post


Link to post
Share on other sites

Just answered myself...

if you go to the flipsolver, to the Volume limits you have a "box size" option, which is linked to your fliptank_initial... if you change it on the fliptank initial, as far as I could tell, you're also changing the liquid level and size of it, but you get extra room... but I still think there might be a better way...

Got it... You need to play with both values! Size Y will increase the bounding box area but will also increase the "depth" of your liquid in the opposite direction. So if you only want it with a certain "depth", you need to play with the center Y!

Hope it works for you!

Cheers!

PS - When you lower the separation you're increasing the "resolution" of your sim and it is as if you increase the number of particles being simmed so things tend to look better but also some issues do become more accute!

Edited by J.Santos

Share this post


Link to post
Share on other sites

Hi, thanks for the quick reply

However, I don't think that is the probably as I have re-sized my container to be 50 meters tall and 20 wide and the clipping seems to be happening very early on in the sim between the heights of about 5-10 meters.

In answer to your question you can re-size your container in the FLIP solver node in the volume motion tab, under the volume tab. In there you can change the box size and the box position. Hope that helps you. :)

Edited by Neo222
  • Like 1

Share this post


Link to post
Share on other sites

Haha you beat me to answering your own question :lol: , glad you managed to figure out your issue.

I still seem to be having the problem, its as if there is some sort of adaptive box creating the flat area on the top of the splash, or velocities are being clamped.

Any more help would be really appreciated, thanks.

Share this post


Link to post
Share on other sites

turn Dynamically Resize Fields off and set the bbox close around your fluid and see if that helps

Share this post


Link to post
Share on other sites

Thanks Dobril, I tried simulating it with the Dynamically Resize Fields switched off, this did seem to fix the problem, however it did dramatically increase the simulation time, which I assume is because it is now trying to simulate the entire container every frame.

After a little more time tinkering around I have also found that if I increase the substeps (default was 2 so I increased it to 4) this also seems to fix the problem and didn't seem to increase the simulation time anywhere near as much as the turning the Dynamically Resize Fields off. Hope this helps, if anyone else comes across this problem.

Thanks again for the help guys.

Share this post


Link to post
Share on other sites

When dynamically resizing is turned on, it pads the resize by 4 voxels. If on the given time step the particle travels more than 4 voxels, it will be limited by the bounds of the resize (which appears as clipping). Increasing the substeps will help avoid this problem as it will decrease the distance the particle will travel per time step but as you found, there is a cost in doing this.

A better solution is on the flip solver > Volume Motion > Solver Tab, increase 'Max Cells to Extrapolate' from 4 to 6. This is the parameter which controls how much to pad the voxel resize.

  • Like 2

Share this post


Link to post
Share on other sites

Nice stuff on this topic!

Hope you have it working by now Sam!

Cheers!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×