Jump to content
Sign in to follow this  
vfortin

Geo light keeps cooking

Recommended Posts

Hi,

Just curious to see if anyone else's having this issue with geometry lights when scrubbing the timeline...

It seems that the light is forcing the evaluation of the geometry even though the light itself is disabled and has its display flag turned off. The referenced geometry also has its display flag turned off.

I can tell by the Performance Monitor that the light is pulling on the SOP network. Delete the light and everything is fast again.

Am I overlooking something here?

Thanks!

Edited by vfortin

Share this post


Link to post
Share on other sites

Hey Mangi,

There's no rendering involved here. All objects are hidden/disabled yet the light tries to cook every time you change the frame.

Here's a hip file for testing:

1 sphere and 1 geo light. Hide or disable both, change frame and feel the lag.

cheers

Share this post


Link to post
Share on other sites

I did this test file

No lag on this end,

Is this what you mean, I was expecting your file.

Mangi

geo_light.hipnc

Share this post


Link to post
Share on other sites

I think you're not experiencing the lag because you're using a simple sphere.

Just to be clear, the problem is not the lag per se, it's the fact that the light is pulling on the graph when it shouldn't.

I'll forward this to support and see if it's the expected behavior...

Cheers

Share this post


Link to post
Share on other sites

I've run into this as well, can't remember if I reported it or not. I just add an extra char to the SOP path to disable the geo light :/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×