Jump to content
Sign in to follow this  
Guest tar

3x+ viewport tumble performance by turning off Origin Gnomon...

Recommended Posts

Guest tar

Can someone else also test this whilst the Sesi forum/bug report is down for scheduled maintenance.

I'm turning off the Display Option/Guides/Origin Gnomon and getting silky smooth, 3x viewport tumble performance. i.e. 8million polygon goes from 6.7fps to 23 fps.

OsX 10.9, GL2.1, AMD 7950, H13.0.222 (also tested in 12.5)

post-8321-0-65136300-1383471458_thumb.pn

post-8321-0-94466800-1383471481_thumb.pn

8_million_polys_124.hipnc

Edited by tar

Share this post


Link to post
Share on other sites
Guest tar

Cool, thanks for testing. Probably an OsX bug as both AMD and Nvidia improve without the Origin gnomon.

Share this post


Link to post
Share on other sites

It looks like drawing the x/y/z text is the culprit. At first I thought that the gnomon might be leaving something like blending on, which would affect subsequent draw calls. But commenting out only the text drawing restores performance to normal levels. I suspect it's triggering some sort of slow codepath in the OSX/AMD driver. I will see if replacing these calls with the more modernized font rendering calls fixes the problem.

  • Like 1

Share this post


Link to post
Share on other sites
Guest tar

Cool as, thanks! NB. The Nvidia GeForce GT120 card is also affected but Intel 3000 is fine.

Share this post


Link to post
Share on other sites

Btw did you guys change the default font used in the UI? I am pretty sure the font used for parameter names, values, VOP node connection texts, etc all seem to be using a slightly different font than previous versions, that's a little bit harder to see when the scale is small, but smoother, more anti-aliased :)

Edited by magneto

Share this post


Link to post
Share on other sites

The kerning of the existing fonts were fixed, so that they're no longer uniformly spaced. This does make them appear a bit finer, but the fonts themselves are otherwise the same.

  • Like 1

Share this post


Link to post
Share on other sites

By drawing the world gnomon after the viewport has rendered all the beauty geometry instead of before, performance jumps back up to the level were it was when the gnomon is off. This has been changed in H13.0.224, for OSX only (since it does not affect other platforms). I'm not going to even attempt an explanation for that one; just going to roll with it.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×