Jump to content

Recommended Posts

Hey everybody,

 

I've looked all over odforce but nobody seems to be having this problem. I attached a video to show my problem but the title should be very self explanatory.

 

https://www.dropbox.com/s/npwjl49t3p908pv/meshjitter.mov

 

the mesh seems to be very noisy, jittery, and I was wondering if anybody knows how to solve it.

 

The way I'm building it is VDB from particle fluid > VDb smooth sdf > VDB reshape > convert VDB. I've also tried getting rid of the smooth and reshape with no better results.

 

 

The particle count is pretty high so that doesnt seem to be a problem.

Share this post


Link to post
Share on other sites

Have you tried varying the VDB From Particle Fluid settings instead of doing manual smooth/reshape?

Share this post


Link to post
Share on other sites

In VDB From Particle Fluid you could try to turn off Resample Input, which leads sometimes to additional jitter

Share this post


Link to post
Share on other sites

Hey Igor, thanks for the reply but unfortunately not even that is working. Right now I'm importing the particles to RealFlow and try to mesh them in there but it seems like I'm havin the same problem.

 

I wonder if it's because the particles are too noisy or something...

Share this post


Link to post
Share on other sites

Then maybe you can try smoothing out the point positions themselves: (untested)

- Use two TimeShift SOPs, one to get the previous frame, another to get the next frame

- Feed the previous frame, current frame, next frame into a VOP SOP, in that order

- Inside the VOP SOP, average the positions from the three inputs and output it as the current position

Share this post


Link to post
Share on other sites

hi!

I submitted this problem and a hip file to support, a week ago. Would be nice to have some solution.

Share this post


Link to post
Share on other sites

I usually get stable meshing with VDBs even for isolated stray particles (not using new VDB From Particle Fluid as I'm still 12.5)

the important thing is setting Voxel Size to half of the particle separation in case of Flip, which means slightly less then half of pscale

Share this post


Link to post
Share on other sites

I'm having the same issue with the same workflow: particles cached out as bgeos (2.6 million particles) > vdb from particle fluid > vdb smooth > vdb convert to polygon.

 

Anyone come up with a solution? I figure it most likely has to do with tweaking the vdb from particle fluid parameters.

 

Edit: I was mostly changing the particle separation and voxel scale, but I think adjusting the influence scale and droplet scale is helping a lot. Decreasing the influence scale a bit and increasing the droplet scale slightly (too much will make the fluid mesh look "blobby").

Edited by briank1458

Share this post


Link to post
Share on other sites

I am new to Houdini but I think I was able to resolve this issue by making my simulation at a bigger scale.  I think the jittering comes from the voxel size of the vdb being inadequate for the simulation.  So sometimes a voxel is read as full and the frame after empty, so if you make the sim at a larger scale the interpretation will be smoother.  The particles have more voxels to pass through and define the resolution.  Just my understanding of this situation...

 

Maybe just adding more voxel resolution would do the same, but it might get more cpu expensive?

Edited by RickToxik

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×