Jump to content
Sign in to follow this  
PaulM3D

OpenGL normal map don't show in viewport & multiple UVSets(for

Recommended Posts

   Hi guys!

 

   I got 2 questions for, I think, advanced Houdini users(or for everyone else).

   I've created standart material in SHOP(Clay, for example), and I turned to OpenGL tab. I want to see as many graphic information as it could be done. So, I set normal map texture in its field - and nothing happened. I've tried to configure it, tried to add light sources, different viewport shading types, even different OpenGL version in Houdini Preferences. Nothing has helped. When I put my normal map in Bump map field - it worked, and worked fine. But why I cant see normal map that I've set in Normal Map field? This is a first quesion, thanks!

 

  Next - I've got 2 differnt UV sets for my geometry, and 3(three) layers of diffuse texture, mixing by alpha channel. And two of them are for uvset1 and third is for uvset2. And it renders fine. But when I try to set this textures as multiple texture layers in OpenGL tab - it working strange. For 1-st texture it uses 1-st uvset, for second texture - 2-nd uv. And for 3-rd - it try to use 3-rd(undefined) uvset, or 2-nd, I don't even know. So, how can I set uvset for each texture layer in OpenGL tab manually? Combining 2 layers in third party software(like Photoshop etc.) it's not an option. I've tried to load in 1-st texture field picture, that has already combined in my shader net(by color mix) - it wasn't worked for me. Maybe, there is some way for send to OpenGL texture field result of my shader net(color type, etc). It(OpenGL field) is working with texture in file, as I can see.

 

   It would be great, if someone can help me with this issue. Sorry for some mistakes in text(I believe, there are some of them), english is not my native language.

 

   Paul

 

 

 

Share this post


Link to post
Share on other sites

normal map ogl doesnt reflect changes as you mention, i tested and submitted a hip file to sesi as a bug to check

Share this post


Link to post
Share on other sites

Thx for reply! Was away. It's pity, I think. Would be great for visual seeing .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×