Jump to content
Sign in to follow this  
乐琢 Urdro

Why things got different when connect to a Null SOP?

Recommended Posts

Why things got different when connect to a Null SOP?

Hello everyone,

I have used Houdini for 4 years and it's the first time I met this strange thing, and I have no idea why this happen.

Any help will be grateful, thanks.

The popnet works fine, it can create fireworks. (img 1)

post-6524-0-77653700-1407391143_thumb.jp

 

But when I connect a Null SOP(others like merge SOP, cache SOP also have the same problem) under it, the result has changed.(img 2)

post-6524-0-90945500-1407391167_thumb.jp


My houdini version is 12.5.316.22
 

And the here is the .hip file :

firework_ud_v001.hip

 

Share this post


Link to post
Share on other sites

The Null SOP by default will try to "instance" the geometry from its input node as to avoid duplicating it. For POPs, it needs to reuse the same geometry every frame. I'm guessing there's some bad interaction between these two behaviours. Try turning off this instancing behaviour by turning on the Null SOP's "Cache Input" parameter.

Share this post


Link to post
Share on other sites

The Null SOP by default will try to "instance" the geometry from its input node as to avoid duplicating it. For POPs, it needs to reuse the same geometry every frame. I'm guessing there's some bad interaction between these two behaviours. Try turning off this instancing behaviour by turning on the Null SOP's "Cache Input" parameter.

 

I have tried it, It's still not work.

Share this post


Link to post
Share on other sites

I opened your file and it seems if you go inside the fireworks node and disable null2 it works fine even when you connect the null to the popnet. 

Share this post


Link to post
Share on other sites

I opened your file and it seems if you go inside the fireworks node and disable null2 it works fine even when you connect the null to the popnet. 

 

Yes, you are right, and it really confused me.

 

However, if I simply delete the "null2", it is still not working. Only disable it can make it right.

Share this post


Link to post
Share on other sites

It sounds buggy... have you tried out a later production build?  I think 12.5.316.22 was the first release production build of 12.5, wasn't it?  It might be that this issue got fixed later on.

 

(This is assuming jennehjenneh used the same build to test this... if not then disregard :-)

 

Edit: Disregarded :-)

Edited by danw

Share this post


Link to post
Share on other sites

It sounds buggy... have you tried out a later production build?  I think 12.5.316.22 was the first release production build of 12.5, wasn't it?  It might be that this issue got fixed later on.

 

(This is assuming jennehjenneh used the same build to test this... if not then disregard :-)

 

I opened the file in 13.0.401

 

 

 

Yes, you are right, and it really confused me.

 

However, if I simply delete the "null2", it is still not working. Only disable it can make it right.

 
I noticed that too. I am pretty sure the collect node is causing it though and it has nothing to do with your nulls.
It seems that it gives an error when similar particles are merged into the same stream.
If you change the order in your collect node you'll see it gives an error in another part of the stream, it can't provide more than one input. For some reason though, disabling null 2 seems to fix one of those errors.. no idea why. 
But if you for example plug your null 3 in after the starburst instead of color_dead you see it will give the same errror and disabling won't fix it. 
 
I checked the fireworks otl (old popnet) in version 13 and it gives the same error when you try to get particles from the same stream into one collect node.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×