Jump to content
arkahtek

HELP!!! My smoke sim is blurry after rendering in 1080p

Recommended Posts

Hey guys i'm new to houdini i've been playing around in it for about a month now and i created a smoke sim moving toward the camera with the help of a forum member here called "Old school" I hope some of you awesome members here can help a newbie again. I used a box as an emitter and changed the dimensions, basically making it rectangular, then i dropped down a volcano from the shelf tools..i wanted to experiment with that instead of using billowy smoke. I've tried as much as what is within my knowledge of houdini ..which is not a lot icon_smile.gif to get this sim to not look so blurry. At 640x388 the sim looks good, but at 1080p the sim looks blurry..I've tried playing with the camera settings, i played with the settings in mantra, i turned up the pixels to 50x50, although the final render you see in the screenshot is on default pixels of 10x10, i tried all of the render options, i've tried sharpening in the pyro solver..with just slightly better results. I've included the hip file and a screenshot of the final render in 1080p. I have the full fx version, not apprentice. Can one of you Masters help me? My eyes is glued to this forum for help so i'll respond very quickly thanks.. icon_biggrin.gif 

post-12008-0-92507600-1409933411_thumb.p

final outward smoke .hip

Edited by arkahtek

Share this post


Link to post
Share on other sites

Hey Donnell,

 

First off keep in mind that the shelf tools for 'Billowy, wispy, volcano, etc' are all referring to different settings of the same network, its all just settings and keyframes on the pyro solver network with a fluid source.

 

On the geometry object that you are importing your simulated fluid from, try using the volume filtering drop down, if you want sharper features try using sinc-sharpening and increasing the volume filter slightly, it may increase render time slightly but it should have the affect you desire.

 

After looking at your scene I would recommend turning off most of the modifiers that you are using on the pyro solver, the shredding and sharpening are mainly there for fire/flame effects and if your using them in conjunction with disturbance and confinement your just asking for artifacts and an unstable simulation. If all I am after is smoke I usually start with just the turbulence field and dissipation, dial that so that the overall motion is what you desire, you could also just use a Gas Turbulence Dop to stack or have layers of turbulence. Try to use Disturbance after you have that dialed in so that it 'adds' detail within your desired overall shapes instead of competing against the turbulence which can cause artifacts/undesired shapes, which are especially noticeable at higher image resolutions. It will also speed up your simulation.

 

If all you are after is a ground plane collision I would recommend using the closed boundaries option of the smoke object in conjunction with a max bounds object on your resize. The smoke will collide with the bottom of the bounding object and the calculation will be faster. Currently you have a ground plane object and a static object that is pointing to another ground plane object. you do not need both of these, your just adding to your simulation time.

 

Hope I was helpful,

 

-Nathan

 

 

Share this post


Link to post
Share on other sites

Thank you nathan..i'm going to work on that, i really appreciate your time on checking this out for me...since i am new to this where would i find sinc sharpening? i might find it before you reply but just in case :) Also where do i find the volume filter drop down?

Edit : found it :)

Edited by arkahtek

Share this post


Link to post
Share on other sites

On any geometry node go to the Render Tab, go down to the Shading Tab, and its there listed as volume filter with a list of filters and a filter width modifier.

 

-N

Share this post


Link to post
Share on other sites

yes thank you..i did everything you advised above. I'm currently rendering a frame..keeping my fingers crossed :) i will upload a screen shot when its done for you.

Share this post


Link to post
Share on other sites

I haven't opened the file, but it really just looks like you need a lot more voxels (lower the division size on the pyro object).

Share this post


Link to post
Share on other sites

hi Ian, i did lower the the division size on the pyro object to 0.3, but i'm still getting that blurry render. what do you suggest?

Share this post


Link to post
Share on other sites

On any geometry node go to the Render Tab, go down to the Shading Tab, and its there listed as volume filter with a list of filters and a filter width modifier.

 

-N

Hey nathan i turned off shredding and sharpening..i set dissipation to 0.175, disturbance to 10, turbulence to 1, and confinement at 2, in the geometry node i set the sinc sharpening and i raised the volume filter width to 2.1 i tried the render again and stopped it halfway thru because i can still see the artifacts and blurriness. what i'm i doing wrong?

Share this post


Link to post
Share on other sites
Guest tar

what happens when you increase the number of voxels

Share this post


Link to post
Share on other sites

hi Ian, i did lower the the division size on the pyro object to 0.3, but i'm still getting that blurry render. what do you suggest?

 

The required division size depends on how big your bounding box is. If you middle click the pyro object or the dop i/o node in sops you'll see the actual resolution (in voxels) of your sim. It should say something like  density: [100,50,100]    Your numbers will be different.  Think of it like this, you are trying to fill 1080 pixels wide of image resolution, if you only have, say 100 voxels the width of the image, you will have ~10 pixels per voxel, and it will look low resolution. You need to get the detail as high as you can without running out of ram, without wasting too much extra sim time (more voxels means longer simulation time), and of course that is all based on what the confines of your shot dictate (distance / screen space / speed / additional shot usage, etc). Based on your screen shot, your sim is filling about 1/4 of the hd image. You don't need 1 voxel per pixel, but you definitely need more voxels than you currently have. I'm just guesstimating this, but you should probably aim for something about 400 voxels wide in the axis perpendicular to the camera. 

Share this post


Link to post
Share on other sites

what happens when you increase the number of voxels

i'm working on it now ..Still rendering ;)

Edited by arkahtek

Share this post


Link to post
Share on other sites

The required division size depends on how big your bounding box is. If you middle click the pyro object or the dop i/o node in sops you'll see the actual resolution (in voxels) of your sim. It should say something like  density: [100,50,100]    Your numbers will be different.  Think of it like this, you are trying to fill 1080 pixels wide of image resolution, if you only have, say 100 voxels the width of the image, you will have ~10 pixels per voxel, and it will look low resolution. You need to get the detail as high as you can without running out of ram, without wasting too much extra sim time (more voxels means longer simulation time), and of course that is all based on what the confines of your shot dictate (distance / screen space / speed / additional shot usage, etc). Based on your screen shot, your sim is filling about 1/4 of the hd image. You don't need 1 voxel per pixel, but you definitely need more voxels than you currently have. I'm just guesstimating this, but you should probably aim for something about 400 voxels wide in the axis perpendicular to the camera. 

ok  cool Ian that is new to me i appreciate that..i just learned something new awesome !!! So how do i add more voxels perpendicular to facing the camera i thought it was by decreasing the division size in the pyro..i had it set to 0.3, now i set it to 0.03  i'm trying to find the voxel info..this mac magic pad is a little wacky when trying to middle click lol..

 

EDIT: i had to download a program to enable middle mouse clicking on my mac magic mouse ..the screen shot of my voxel info is on the next page

Edited by arkahtek

Share this post


Link to post
Share on other sites

The required division size depends on how big your bounding box is. If you middle click the pyro object or the dop i/o node in sops you'll see the actual resolution (in voxels) of your sim. It should say something like  density: [100,50,100]    Your numbers will be different.  Think of it like this, you are trying to fill 1080 pixels wide of image resolution, if you only have, say 100 voxels the width of the image, you will have ~10 pixels per voxel, and it will look low resolution. You need to get the detail as high as you can without running out of ram, without wasting too much extra sim time (more voxels means longer simulation time), and of course that is all based on what the confines of your shot dictate (distance / screen space / speed / additional shot usage, etc). Based on your screen shot, your sim is filling about 1/4 of the hd image. You don't need 1 voxel per pixel, but you definitely need more voxels than you currently have. I'm just guesstimating this, but you should probably aim for something about 400 voxels wide in the axis perpendicular to the camera. 

i changed the division size lower, but how do i get it to 400 voxels i still see the same numbers as in the screenshot when i right click on the pyro node, do i have to re-simulate to see the voxel numbers changed

Share this post


Link to post
Share on other sites

i changed the division size lower, but how do i get it to 400 voxels i still see the same numbers as in the screenshot when i right click on the pyro node, do i have to re-simulate to see the voxel numbers changed

 

Yes,

you have to resimulate because the data is still the old version.

Share this post


Link to post
Share on other sites

Hey i just wanted to tell all of you guys thank you..NATHAN, IAN and FRANCIS..you guys taught  me a lot. The quality of the sim improved greatly by adding more voxels..something i learned from you guys :) When i turned the division size in the pyro object to 0.07, i got  something like 667 voxels on the z axis which was perpendicular to the camera. i have an older iMac mid 2011 hd radeon card 6750 so we all know how long my sim time is going to take on this card ..lol I'll post a screen shot of a frame so you guys can see. Hopefully this thread helps another newbie such as myself. you guys are awesome thanks again

Edited by arkahtek

Share this post


Link to post
Share on other sites

Hope I am not too late,apart from increasing voxel counts but maybe you can try volume quality and under mantra>shading>Shading Quality Multiplier could help improve as well :D

Share this post


Link to post
Share on other sites

Hey dszs, you are not to late..I'm still tweaking this sim, so thank you for the advice I will apply your input as well..then post a screen shot of the render. Thanks again :)

Share this post


Link to post
Share on other sites

Just so you know, the video card, by default is not used for simulations, and since you are on a mac, I think the option for OpenCl is disabled (?)... but for a simulation this high of a resolution, you would run out of video card memory anyway.  You will be relying more on cpu and system memory, which hopefully you have a lot of.  ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×